New release: Notepad++ v8.1.4



  • Notepad++ v8.1.3 Release is available here:
    https://notepad-plus-plus.org/news/v814-released/

    Notepad++ v8.1.4 new features, enhancements & bug-fixes:

    1. Fix regression of find/replace and file open performance issue. (Fix #10398, #10296, #10260)
    2. Make dark mode compatible with Windows 11. (Fix #10299)
    3. Make current existing plugins’ toolbar icons display in both light and dark mode. (Fix #9959, #10388, #9809)
    4. Support TypeScript language (syntax highlighting, auto-completion & function list). (Implement #10353)
    5. Fix security flaw issue in uninstaller. (Fix #10191, #6165)
    6. Add Insert Date Time commands for both short & long format. (Implement #497, #2821, #8184, #8302)
    7. Fix file dialog append extension issue with RTL languages. (Fix #10397)
    8. Fix Find-in-Files “Follow current doc” not working issue when Default Directory is set. (Fix #8045)
    9. Enhance dialogs visual look & feel. (Fix #10384)
    10. Fix LICENSE text display problem in installer. (Fix #10370)

    The auto-updater will be triggered in 1 week if there’s no critical bug found.

    Enjoy



  • No problem to report, just a bit more info on 6. Add Insert Date Time commands… :

    The new commands are located on the new Insert submenu on the Edit menu:

    dd068f99-b06d-4b85-8776-2fccd99d8269-image.png

    I suppose the exact format of the date is Windows locale specific, but for me, here’s what the two new commands produced, along with what Notepad.exe produces when I press F5 in that program (hint: appears same as N++'s short format):

    813af5c3-0578-4305-b667-72691ce51664-image.png



  • There seems to be an issue with the Find Previous command.

    • It does not work from the shortcut key Shift-F3 (No conflicts for that key assignment are indicated).
    • It does not work from the menu.
    • In the Find dialog, in “2 Find Buttons Mode”, the Find Previous (Up-arrow) button is greyed out.


  • @Bob-Silvern ,

    That’s been that way since v7.8.7.

    The user manual describes the setting you need to change in order to allow regular expression searches to work in backwards mode, if you understand the risks



  • Installed NPP++ v8.4.1 and tried to install plugins. The installation did not place a Notepad++ folder in programdata. The new plugin routine is to install plugins in programdata under PluginName folder and ProgramName.DLL in the folder. Is there a workaround.



  • Sorry, installed version 8.1.4 I can place Notepad++ folder in programdata but what should it contain to accept plugins.



  • @Vernon-Stockton ,

    As far as I can tell, the behavior is nothing new to Notepad++ v8.1.4, so the question doesn’t really belong in this thread. This topic is for regressions – changes of behavior that came about in v8.1.4 that weren’t present in previous versions. But I’ll give some pointers anyway.

    If you install Notepad++ into the standard C:\Program Files\Notepad++\, then the plugins will be installed into subdirectories of C:\Program Files\Notepad++\Plugins\ – if your normal user has write permission to that folder, then it can do it without special permission; if your PC is more locked down, you may need to run as Administrator in order to install plugins (or at least use Admin privileges to change the permissions of C:\Program Files\Notepad++\Plugins\ so that your normal user can have write access to that directory hierarchy) (Read the above as Program Files (x86) if you are installing 32bit Notepad++ on a 64bit OS.)

    If you install Notepad++ into the less-usual C:\ProgramData\Notepad++\, then the plugins will be installed into subdirectories of C:\ProgramData\Notepad++\Plugins\ – if your normal user has write permission to that folder, then it can do it without special permission; if your PC is more locked down, you may need to run as Administrator in order to install plugins (or at least use Admin privileges to change the permissions of C:\ProgramData\Notepad++\Plugins\ so that your normal user can have write access to that directory hierarchy) *

    If you install Notepad++ into some other X:\FlibbertyGibbet\Notepad++\, then the plugins will be installed into subdirectories of X:\FlibbertyGibbet\Notepad++\Plugins\ – if your normal user has write permission to that folder, then it can do it without special permission; if your PC is more locked down, you may need to run as Administrator in order to install plugins (or at least use Admin privileges to change the permissions of X:\FlibbertyGibbet\Notepad++\Plugins\ so that your normal user can have write access to that directory hierarchy)

    *: Please Note: the ProgramData folder is often hidden, or otherwise more locked down by the OS than even Program Files. That seems an odd place to me to install a program… but to each his own. As long as you have write permission, either normally or through run-as-admin, it should work



  • FYI, auto-update is triggered to v8.1.4.



  • Most likely too late/not the right thread, yet found nothing better …

    Auto-Completion Typing removes forced language interpretion and goes back to (extension) default.

    Example:

    • an XML file with native SQL
    • force the XML to be interpreted as SQL (Language → S → SQL)
    • start typing → the file is interpreted as XML again

    Navigating by cursor/mouse, highlightning of text, even deleting nor inserting text does cancel the forced language interpretion … yet as soon as the first letter is typed …

    <?xml version="1.0" encoding="UTF-8"?>
    <sql><![CDATA[select * from dual]]></sql>
    


  • @Peter-Stücklschwaiger ,

    <?xml version="1.0" encoding="UTF-8"?>

    Do you have XML Tools? In this recent thread, it was pointed out that XML Tools has an option to “Set XML Type Automatically” – if that option is enabled, then the XML Tools plugin will see that the file is XML (because of that first line), and change your file type for you.

    Edit: just confirmed XML Tools defaults that option on when you first install the plugin



  • @PeterJones said in New release: Notepad++ v8.1.4:

    Do you have XML Tools? In this recent thread, it was pointed out that XML Tools has an option

    Thanks a lot – disabled that option → works like a charm.

    At least I do know now the meaning of “Set XML Type Automatically” … I always wondered …
    and my Google/Search-Fu is most obviously not as good as I thought



  • Hey, great job with the release, but can we please get back “Standard icons: Large”? Not everyone likes Fluent UI (even in large) :)



  • Ctrl+Shift+F5 is a long awaited feature!!!
    lol, i use date as version and this was annoying to not have it built-in.

    Thank you a lot!
    Have a very nice day!



  • @Simon-0 said in New release: Notepad++ v8.1.4:

    Ctrl+Shift+F5 is a long awaited feature!!!

    Hmmm. There’s no feature tied to Ctrl+Shift+F5. Try to get your facts correct before posting.



  • close tag auto-completion should cover PHP and jsp files too (not only html and xml files)

    hi guys, thank you very much for this fabulous text editor.
    I think that close tag auto-completion should cover PHP and jsp files (not only html and xml files).
    the reason behind this: html tags are used in abundance inside PHP and jsp file

    thank you very much



  • @freedom-ilias

    To quote Peter from above:

    As far as I can tell, the behavior is nothing new to Notepad++ v8.1.4, so the question doesn’t really belong in this thread. This topic is for regressions – changes of behavior that came about in v8.1.4 that weren’t present in previous versions.



  • @Alan-Kilborn
    thank you for your remark



  • Whenever the window of Notepad++ is started or restored after minimizing, Notepad++ does not check if the remembered coordinates are still valid (e.g. after changing screen resolution, switching off an external monitor on a laptop etc.). So the window can be restored to an invisible coordinate.

    Getting the Notepad++ window back into the viewport is hard (my solution: Change another programs’ window with Windows+CursorLeft, so Windows will ask for a window to be displayed on the right side, chose Notepadd++)



  • @Tom-Stein Thanks for the tip about Win+Cursor to move a window between monitors (I’d never heard of that before). This helps when one of the monitors uses DVI-D which has no way of telling Windows that the monitor is switched off **. Another way to put Notepad++ onto an available screen without the “ask to put on the right side” question is to click on it on the taskbar, or ALT+TAB to select NotePad++, and then use WIN+Cursor to move Notepad++ over to a powered screen.
    ** So the issue can never be fully solved, since some display connection protocols have no physical way to tell Windows that a monitor isn’t switched on.



  • A Very Happy Notepad++ user for many years … Thanks!

    As of this morning, Notepad++ refuses to open properly. I get a window that remains all white, then a “Not responding” error message, and have to kill the process.

    I’m running Windows 10, OS Build 19043.1237.

    Any suggestions would be greatly appreciated.
    a0a1398f-f917-46c7-a77c-213833dd545a-image.png


Log in to reply