XML file / Language set to None (Normal Text) / XML Tools option Set XML type automatically



  • This has been bugging me for a while and I just found the solution as I was typing a question about it in the Help wanted section… Hopefully, this might help someone else.

    When working with big XML files, I set the Language to None (Normal Text) to speed things up. But as soon as I was typing anything, even just [ENTER], the XML highlight was back, slowing down Notepad++ quite a bit.

    I finally realized that the culprit was the Set XML type automatically option of the XML Tools plugin. This option is selected by default I think, so I didn’t really noticed it before this.

    With this option being unchecked, my XML file now stays on “None” and no highlight is coming back.



  • @Bruno-Guillemette said in XML file / Language set to None (Normal Text) / XML Tools option Set XML type automatically:

    When working with big XML files, I set the Language to None (Normal Text) to speed things up. But as soon as I was typing anything, even just [ENTER], the XML highlight was back, slowing down Notepad++ quite a bit.
    I finally realized that the culprit was the Set XML type automatically option of the XML Tools plugin. This option is selected by default I think, so I didn’t really noticed it before this.

    Good tip on the set XML to Normal Text for large file if you don’t need highlighting / function list but do need performance and I do have XML Tools installed, but not that option checked - so I wouldn’t have noticed it, but experimenting with it, I do see your behavior.

    I’m going to leave XML Tools Set XML type automatically unchecked so Notepad++ can autodetect and I can “reset” to Normal Text without worrying about it switching auto-magically for me.

    Cheers.


Log in to reply