DSpell not recommending corrections for misspellings



  • NP++ 64 bit v7.9.2
    DSpell installed but executing spell check does not offer corrections for misspelled words. IT just highlights the words. Searched for how to configure but nothing. Prior spell check (Aspell??) worked perfectly.

    Help please.
    Tks in advance.



  • @Tom-O said in DSpell not recommending corrections for misspellings:

    DSpell installed but executing spell check does not offer corrections for misspelled words.

    It seems to offer alternatives through the right-click menu option, see
    e2a25070-8acb-4173-8ffe-a6e2996bde2c-image.png

    I am on 8.1.4 although I’m not aware of any changes in DSpellCheck to fix any problems. This is a “temporary file” (new 2). Are you checking a “program” file, what is your extension because there was an issue with other types of text files a while ago. Maybe you have the same problem. I’m trying to locate that post now.

    Terry



  • @Tom-O ,

    DSpellCheck works just fine with Notepad++ 64-bit v7.9.2.

    With the Hunspell dictionary (the default, and the easier one to use), you just have to 1) install the plugin, 2) select Hunspell dictionary, 3) click the Download button and select the language(s) you want for spell check, 4) type a misspelt word.

    I was just able to unzip a fresh NPP v7.9.2-64, install the plugin, and set it up and working in less time than it’s taken to type this post so far:

    fc585706-22ae-460b-b2c3-81b5dd1758f9-image.png

    fbb83fd0-7cb5-4bf7-ace2-09a96fcac6e3-image.png

    With the Aspell, it’s a bit more difficult, because you have to have already installed the Aspell-15.dll somewhere, and then point the DSpellCheck settings to point to that external DLL

    Searched for how to configure but nothing.

    There is a configuration for it: at the bottom of the Simple tab in the configuration, it has a pulldown for “Use N++ Context Menu” (default) vs “Special Suggestion Button” (non-default)

    018dbe46-da9c-4f24-92ff-6863d67a3b83-image.png

    PS: Terry’s suggestion about the file type is important; Terry’s previous post here has more about the problem.



  • @Terry-R said in DSpell not recommending corrections for misspellings:

    I’m trying to locate that post now.

    This is the post

    So it appears that “real” TXT files only are working correctly. So if your file isn’t a “temporary” file or a real TXT file consider making it a TXT file temporarily to see if that resolves your problem.

    Terry


Log in to reply