dot extension not well when dot in file name



  • Hi, when I save a file with a dot in the name e.g. ‘infos about postgresql v12.0’, and save it to normal text, NotPad++ don’t add the ‘.txt’ extension. As well on other languages, like ‘.sql’.

    A running example, I copy/paste the help of pg_dump from the official french website to NP++. And want to save it to ‘pg_dump_v9.5.txt’. NotPad++ save it to ‘pg_dump_v9.5’, without the right extension .txt.



  • @PaKaL600Qualis ,

    Notepad++ correctly adds the extension if you don’t provide one. Since Notepad++ version 8.0, it has even provided a checkbox in the Save As dialog so you can make sure you know whether or not it will automatically add the extension. If you are using an older version than v8.0, there were options elsewhere that would affect it, but in general, even older Notepad++ versions correctly add the extension under normal default circumstances.

    If you still believe your version is having problems:

    1. go to the https://www.notepad-plus-plus.org/downloads/ official download site and download a portable edition of the most recent version listed (right now, v8.1.4, but soon to be v8.1.5) and unzip to a writeable directory. Close all instances of Notepad++ and run the notepad++.exe that’s in the unzipped portable, and confirm that it works correctly on the newer version. If it does, then install the newest version in your normal Notepad++ location.
    2. if that doesn’t work, share the ?-menu’s Debug Info in the forum (for both the portable and for your installed), and give screenshots of things like the Save As dialog and the settings > preferences pages (especially MISC and Default Directory, which were the older preference locations for the checkbox that is now in the Save As dialog)

    official reference on the Save As extension: https://npp-user-manual.org/docs/preferences/#preference-toggles-in-other-dialogs


Log in to reply