NPP will not finish upgrade



  • I have Windows Server 2012 R2 (no we cannot change this). I tried to upgrade to NPP 7.5.6 (32bit) and each time I open a .txt file by double clicking it, I get this message: “There are still some pending actions to complete installing or removing some plugins. Would you like to do these now?”

    I click the Yes button and then I get an error “It has not been possible to validate the integrity of ‘poython27.dll’ needed to install or update a plugin. Do you want to copy this file anyway?”

    I click the Yes button and I get error #2 in an infinite loop.

    Could this be a Windows permissions problem? Where is NPP trying to copy python27.dll to?

    Thank you!



  • @Chuck-Roberts-0 ,

    I have never seen error messages like that before. But when I was on a Notepad++ as old as NPP v7.5.6, I had never tried it with Windows Server 2012 R2, so maybe there’s something with that specific OS.

    It sounds like you have the PythonScript plugin installed, but that it might not be installed properly. I would recommend uninstalling the PythonScript plugin for now, and see if the problem goes away. If it does, then try re-installing PythonScript and see if it works better for you.

    It also surprises me that you want to upgrade to v7.5.6 – that’s years out of date at this point. Looking up Windows Server 2012, that’s apparently based on Windows 8. All recent versions of Notepad++ through v8.1.5 (and even v8.1.6-RC, which will likely release in a couple days) should still be compatible with Windows 8-and-similar editions of Windows. So you might consider installing the most recent Notepad++ rather than one that’s that old. (The one caveat: since you are starting with a Notepad++ version before v7.6.3, where the plugin organization completely changed, you will need to re-install all of your plugins if you upgrade to v8.1.5 . I suggest writing down a list of all the plugins you actually use – ignoring “Plugin Manager”, which isn’t compatible with anything newer than v7.5.9 – then install v8.1.5, then use the Plugins > Plugins Admin interface to install your desired plugins.


Log in to reply