Notepad++ and Linux EOT on existing files - driving me nuts



  • Firstly let me say - Notepad++ is wonderful - use it all the time.

    But - I’m spending a lot of time right now with winSCP, reading Linux .sh files on my PC - and this EOL thing is driving me nuts. I can set Notepad++ to automatically use Linux EOL on new files - no problem, but every time I read in an existing .sh file - it insists it is DOS format and starts adding in extra \r characters. Please, someone tell me there’s a setting to fix this permanently…



  • If your local computer is running Windows and the remote system is running Linux, you’ll probably want to change the way WinSCP handles plain text files. By default, WinSCP converts line endings between systems so on each machine the file is stored with the machine’s system default settings.
    I suggest that in WinSCP, you go to Preferences/Transfer/Presets, double-click on “Text”, and change “Transfer Mode” from “Text” to “Binary”. This should do the trick as long as you don’t save with Windows line endings locally by accident.


Log in to reply