Find and Replace strings, Edit Text behaviour in N++



  • I am about to change into a new plaintext editor, and that is a HUGE decision, as you can imagine. I was feeling strongly inclined to adopt N++, however I find a ““feature”” to be most annoying. It is driving me furious, and now I feel about to give up on N++ completely.
    .
    I am talking about the Find/Replace dammned ““semi-tranparent window”” and the small devilish ““suggestion window”” that keep chasing after me during Find operations, when I place the cursor on a string and type something. That behaviour seems like purest and absolute S…T to me, forgive me the generous and liberal N++ team and forum. A similar ordeal happens on each and every click/edit operation, when N++ always has ““suggestions”” to make. Can I edit my text or code in peace, please? Perhaps as an option: ““suggestions welcome”” or ““don’t disturb, please”” ?
    .
    That behaviour strongly reminds me of MSVista, MSWord “clip” and other, messing the workspace with transparencies, interruptions, options, autocomplete, suggestions, silly warnings, are you sure?, do you really want to? and the like. I will always strive to get rid from that stuff, period. I am just unable to work with such tools around. Is there a way to get rid from that, and just have a Find/Replace standard window docked somehere, the cursor at the F/R spot, and (maybe) the found search string just hightlighted? I could then peacefully point/click on Replace or type anything I want, and go Find Next or close the F/R window. And I want to type in peace, please, without lists of suggestions above/below each word I type.
    .
    A “Keep on top” option for the N++ window would also be most convenient, just an opinion. Perhaps N++ just isn’t the plaintext editor I need, sigh… I want a less intrusive tool, not more.
    Thanks for reading about my predicament,
    Ed



  • You can disable the transparency in the Find/Replace dialog.

    You can turn off auto completion in the Preferences.

    The Find/Replace dialog is not dockable.

    This site has a plugin called “TopMost” that sounds like it will keep Notepad++ on top of other windows.



  • Thank you very much dail, I feel ashamed for not seeing that option right on the S/R window, I did not expect to find it there. That makes things much lighter, however the devilish “suggested words” list keeps appearing at almost all edits I make. Can I get rid of that? Can I even hack somehow the Notepad++.exe to just KILL that little devil?
    Thanks again,
    Ed



  • Did you look at the preferences? Settings -> Preferences -> Autocomplete and uncheck “Enable auto-complete on each input”.



  • Oh God, I feel so happy, and so embarassed. I did not read your entire answer before replying. The devilish “autocomplete” is now just ticked off, all right. No need to kill, just tick it off; shame on me, and many thanks on you. A probable serious engagement to Notepad++ is now on sight.
    Thanks again,
    Ed
    P.S. Maybe of use to you: If you may sometimes feel in need of a Keep on Top utility, I use tiny Deskpins.exe to good measure.


Log in to reply