nppcrypt v1012 test



  • hi,
    i am in the process of finishing a new update for the plugin “nppcrypt”. it would be very nice if someone with a litte bit too much time on his hand could try it out before i put it up on the pluginmanager: http://www.cerberus-design.de/nppcrypt/nppcryptv1012alpha.zip
    thank you very much beautiful & helpful stranger!



  • Hello Jean-Paul

    I downloaded the last 1.0.1.2 version of NppCrypt, but when I placed it, into the Plugins directory, a small window appeared, on starting my 6.8.1 version of N++, with the text below :

    Load library is failed.
    
    Make "Runtime Library" setting of this project as "Multi-threaded(/MT) may cure this problem.
    
    This plugin is not compatible with current version of Notepad++
    
    Do you want to remove this plugin from plugins directory to prevent this message from the next launch time?
    

    I must add that my configuration is quite old : a Window XP SP3 laptop, with 1Mo of RAM ( Incredible, isn’t it !! )

    By the way, did you read my last post to you, on September 2014, relative to your previous version 1.0.1.0 :

    https://sourceforge.net/p/notepad-plus/discussion/482781/thread/9b3004fa/#e400

    I don’t see anything to change to what I said, in that post !

    Best regards,

    guy038

    P.S. :

    I’ve just tried your old 1.0.1.0 version, with my 6.8.1 N++ version => It still works nice :-)



  • hi!
    thanks for your reply. i did read your old post but just forgot to change the cancel-button caption. thankfully that’s easy to fix. your problem with the new version on the other hand is quite puzzling to me, because the plugin is compiled with staticlly linked runtimes (the suggetion of the error-message) and with the platform-toolset “v140_xp” which should ensure compatibility with windows xp. maybe i can try to compile it with an older version of visual studio (like 1.0.1.0). it is highly unlikely that this problem has anything to do with the version of notepad++, because it the plugin runs fine with 6.8.3 on the three systems i could test it on :/


Log in to reply