NotePad++ - One line instead of two



  • So i have a loads of lines in my txt file. I can’t explain much but I’ll give an example of what i need… I need it in one line not two

    notepad
    :test

    so i want it converted into one line

    notepad:test

    I have tone of these lines. So i want to replace all how do i do this fix?



  • Open your text file
    in Search+Replace
    in Search Mode box
    select Extended (\n, \r, \t…
    Find what \r\n:
    Replace with :
    .
    Click Find Next
    Click Replace
    Repeat to satisfaction
    Click Replace All
    end
    .
    If you would like to “see” the working details, choose ¶ (Pi - show all characters Menu Icon)



  • You’re awesome but not close yet.
    The line get’s bigger and bigger. I want one line at a time.
    Also it adds extra : to it too :(

    Any suggestions?



  • -------from:
    notepad
    :test
    notepad
    :test
    notepad
    :test
    ------- I got lines such as:
    notepad:test
    notepad:test
    notepad:test
    ------- Not
    notepad:testnotepad:testnotepad:test
    .
    Check your settings. Put exactly “\r\n:” and “:” in Search/Replace boxes, with Extended mode selected. Test again. If no good, post a sample from your actual source stuff, at least 20/30 lines long.



  • You’re damn awesome for helping me out, finally. I just forgot to put : at the end of \r\n


Log in to reply