NPP doesn't show spaces



  • System: Windows 10 x64, npp 6.8.3

    Hi!

    My npp installation doesn’t show spaces. Show all characters is activated, Tab, newline etc. are shown correctly, but spaces aren’t.
    Screenshot
    Does anybody have an idea to remedy this? I already reinstalled npp (including deleting the Notepad++ folder from %appdata%)

    Best regards



  • Hi Johann,

    I’m not sure what exactly do you mean? I can see small orange dots that represens SPACE in the screenshot you have provided. It looks fine to me. Maybe it’s just question of your screen resolution, zoom, DPI, font, … that it’s not visible better?



  • Hi Tomas!

    You’re right, the dots are there - the are just so small on my screen that you cannot discern them from the background unless you’re in front of the screen. Since they don’t scale when zooming, I have to try to make them bigger with the help of a macro or something like that.

    Thanks for your input!



  • Hello Johann and Tomas,

    I’ve got a simple work-around to make the orange dot, for space representation, more readable !

    • Open the Menu option Settings - Style Configurator...

    • Check that your selected theme, is Default (stylers.xml)

    • Select Global Styles, in the Language drop-down list

    • Select White space symbol, in the Style drop-down list

    By default, the foreground colour of this dot, is a light orange ( #FFB56A in a RGB representation )

    Changing this colour for the true orange one ( #FF8000 ) will improve readability of this symbol :-) So :

    • Click, on the right, inside the small orange square

    • Chose the true orange colour ( 4th row, second column )

    • Finally, click on the Save & Close button

    Et voilà !

    On the same way, if you’re using a theme with a dark background, you’d better change the colour of the dot to a light one, even the white colour ( #FFFFFF ) !

    Best Regards,

    guy038



  • Hi,

    change of White space symbol color was also my second suggestion. Still it’s not looking perfect even when color is changed. Problem is also that it won’t use background color for these symbols. So maybe try any dark theme (Menu \ Settings -> Style Configurator… \ Select theme), it’s easier to distinguish this symbol that way (at least to me) if it’s really important.

    Other option is to check it using Search or HEX-Editor plugin. Search will mark hits in result with background, so it’s easier to distinguish. You can change style of hits in:

    1. Menu \ Settings -> Style Configurator…
    2. Language: Search result
    3. Style: Hit Word

    Another thing that could help, would be add option to define custom character for this. But it could easy interfere with writing characters. Maybe define some different (optional) symbols to be able to easier distinguish this.

    It all depends what exactly is your kind of work with Notepad++, so what would you like to achieve, and what can help you the most.

    You can also suggest some change as feature request that could help you while working with Notepad++.


    Best regards,
    Tomas


Log in to reply