Ctr+l problem



  • Hello, I’ve been using NP++ for a few years now, as a default text editor and for some html coding.
    Since I’m doing a lot of fansubbing in NP++ I tend to copy and paste some tags, or codes very frequently, and the problem is that for some reason, it copies text all by itself, or by some form of automation or something.

    Naimely, I’ve pin-pointed the problem to the usage of ctr+l option to delete whole selected rows. Whenever I use this it copies the deleted row/s. It wasn’t like that before, as much as I can remember, or maybe I haven’t used it quite often so I didn’t notice :/

    Is there any kind of option for this that I didn’t see or something? 'Cause it gets rather frustrating when I constantly paste the line that I haven’t even copied in the first place, and I’ve deleted it on purpose :/

    Note to the mods/admins:
    I’m terribly sorry for the previous topic, since I couldn’t edit it, i removed it.



  • Hello, Bojan Megla,

    Your problem can be easily solved. Indeed !!

    The CTRL + L action, corresponds to the Scintilla command SCI_LINECUT ( on line 91, of the Scintilla commands tab of the Shortcut Mapper ( Menu option Settings - Shortcut Mapper… )

    If you prefer to delete a line ( or a selected block of lines ), WITHOUT copying in the clipboard, just use the CTRL + SHIFT + L shortcut, which corresponds to the Scintilla command SCI_LINEDELETE ( on line 90 )

    Et voilà !

    Enjoy our loved editor !

    Best Regards,

    guy038



  • hmm, why didn’t I think of that, I wonder :)

    Thank you very much ;)



  • Hi Bojan Megal,

    In addition, don’t forget that you can, freely, change any shortcut, in the Shortcut Mapper feature ! Just take care not using an already used one ! I’m not sure, but default N++ shortcuts should have priority on user’s ones.

    But, for instance, you could invert, without no problem, the two shortcuts CTRL + L and CTRL + SHIFT + L !

    Cheers,

    guy038



  • Yes, I’ve done exactly that :)

    Thanks for the help ;)


Log in to reply