COBOL syntax highlighting



  • Can anybody explain how I can get COBOL syntax highlighting working.

    I’ve downloaded the cobol and cobol-ac files from the N++ library, tried putting each one in the plugins/API forlder and chosen COBOL as the language required. All I get is a straight black background and white foregound display of code.

    Thanks



  • To get the COBOL syntax highlighting you don’t need to download anything, it is built in. Use the menu Language > C > COBOL.



  • I’ve already tried that [Language > C > COBOL] with no effect. And COBOL is not listed among the languages in [Settings > Style Configurator] so, as I said, I’m just left with white text on a black background.



  • Do you see syntax highlighting for any type of file? If not, in the Style Configurator, do you by chance have the Enable global foreground colour and Enable global background color checkboxes checked?



  • I see colour and highlighting for C and Objective-C but this appears to be controlled by the theme chosen i.e. Vibrant Ink. If, with a COBOL program open in N++, I choose C as the language I get colur and highlighting but it’s the same as for C and Objective-C.

    I don’t have the Enable Global foreground and background checkboxes checked. If I did I get yellow fg on orange bg.



  • I think the problem (or at least an indication that the problem exists) is that you don’t see COBOL under Settings–>Style Configurator, but I have no idea why it wouldn’t be there.

    Perhaps some helpful NPP user one can answer that???



  • by the theme chosen i.e. Vibrant Ink

    Looks like Vibrant Ink doesn’t have any style configuration for COBOL. Only a few non-default themes have it for COBOL at all.


Log in to reply