Notepad ++ v6.8.6 fails to open files from shared/network drives

  • I have a network drive connected to my windows 7 machine. Notepad ++ v6.8.6 fails to open files from shared/network drives.

    I am able to open files from network/shared drives using notepad, sublime Text, etc.

  • I have the same problem. The files in the network i had them mapped in Windows 7 and Notepad++ could find them and I could open either by navigating to them from Notepad++ or by dragging and dropping into Notepad++.

    But I just upgraded to Windows 10 and then I was prompted by the Notepad++ notifier to upgrade to the latest Notepad++ (v6.8.8). Now the mapped drives, which are shared drives, i cannot load any of the text files into Notepad++ (*.css, *.xml, *.txt).

    Is there a setting i need to adjust in Notepad++?

    Thank you very much for any feedback on this issue. I love this utility and I have been using it for the last couple of years and recommended it to my friends for their text editing needs.

  • Hello David-Gutierrez,

    did a test with my NAS and windows 7 x64 npp 6.8.7 and windows 10 x64 and npp6.8.8.
    Both npps were able to retrieve files from NAS.

    Do you try to open the files by using the file open dialog from npp and
    DRIVE:\YOUR_FILE.txt or \NAS\SHARE\YOUR_FILE.txt or do you
    open the explore and right click on the files a choosing EDIT… ?

    Is MS notepad able to open the files?


  • I am having the same issue with version 6.8.8, this is the latest version as of today.

    I have a network drive on a linux machine which I have shared using smb. My host machine is Win10 x64 on which I run npp and edit the source. I have mapped my network drive as X: on my win10 machine.

    In Npp, when I try to do File -> Open, then put the “X:” in the path, npp says that “Drive X: does not exist, check the drive and try again”. However, I am able to open X: drive in file explorer. I am also able to open files in X: in other editors like notepad.
    I also tried to unmap and remap the network drive. That did not help.

    Please help… Most of my work is on network drives and I am not able to use my favorite npp to edit my source…

    Thanks in advance!

  • The network drives were working for me before, so I went back to older versions, skipping a few versions at a time, went as far back as notepad++ version 6.2.3, but that did not resolve the issue. I know for a fact that it was working earlier when I had installed Npp a few years back. But the same old version isn’t working now on win10.

    So I tried starting from a clean slate. I uninstalled the currently installed version. Purged all mention of notepad++ from the registry manually by searching for notepad++ and deleting all keys mentioning it, deleted everything from the installation directory “C:\Program Files (x86)\Notepad++”. Rebooted the machine, then installed the latest version 6.8.8.

    And it works now. I am now able to open the network drives.

    Hope this solution works for other folks who use Npp.

  • After troubleshooting found that the culprit for me was the Notepad replacer 1.1.6, since it was the latest version i uninstalled it and everything was working… !!

    Hope this helps others !!!

  • !! Sorry couldn’t find the edit option !!
    Another thing that i found was when you have Notepad++ opened in administrator mode. (I used to for the hosts file)
    It wouldn’t open the remote files, if i reopened the notepad ++ with the users privileges it opened fine.
    Hope these and the previous post helps someone.

  • @Vivek-Dave

    Thanks a lot Dave! Same problem here (file on network drive won’t open with npp in administrator mode on Win10). Npp i s7.2.2.

  • Don’t know if it is related, when I used to save files form Notepad++ to SAMBA shares it would reset file access mode to the SAMBA configuration default. It is specifically annoying with respect to ‘x’ bit for scripts.
    I found out that Notepad++ uses fopen/fclose/fwrite for files. It better use _open/_close/_write instead which eliminates the problem I had.
    I use an old version (6.7.8) that I patched for myself so I don’t know if it changed since in mainline npp.

    It would be interesting to debug it from the SAMBA side (logs ?) to see if we can see Notepad++ attempts that are denied or whether it is blocked in the Windows side.

  • Had the same problem & found a fix here

    Basically add a new DWORD to your registry called HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Policies/System/EnableLinkedConnection & give it a value of 1. Reboot & all should be good.

  • @Nashvi-Labs said:

    Notepad ++

    Recently, I edit the file with Notepad++ on my Latitude E6530, suddenly the machine closed down, Iam not sure what problem, is there any bugs with Notepad ++ or my Latitude E6530 battery is out of power.I forget to take the adapter to charge, who can tell me how to check it?

  • I didn’t read everything here, but I did notice if you start it in Administrator mode, you do not see the network drives. Normally does however see the network drives.

  • @Rob-Manley If you didn’t read everything, at least go back up and read the post from @Stickleback-Ne. He has a fix for it, if you’re able to apply Registry changes. :)

  • @Stickleback-Ne said:

    Had the same problem & found a fix here

    Basically add a new DWORD to your registry called HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Policies/System/EnableLinkedConnection & give it a value of 1. Reboot & all should be good.

    This fixed the issue for me, but please note the typo. The new DWORD should be “EnableLinkedConnections

  • I use Notepad++ v7.8.5 on Ubuntu 18.04. I run Ubuntu and Windows in dual boot mode.

    I was not able to open text files in Windows (automatically mounted onto Ubuntu as /dev/sda3). Below is what I found to be useful.

    Open UbuntuSoftware > Find Notepad-Plus-Plus (WINE) > Click on it > Click on Permissions > Find “Read/Write files on removable storage devices” > turn it ON.

Log in to reply