Files won't save with .txt extension



  • OK, this is starting to drive me nuts. Recently I encountered a problem with Notepad ++ (ver 6.8.6) where all files that I try and save save as . all files. I need files to save as .txt files. EVEN if I choose .txt text files from the drop down in the save box IF I don’t add “.txt” to the end of file names, they will not be saved as text files. What the HECK is going on? I think that this just started recently as I have been using ++ for a long time without this issue.

    Thanks,

    Justin



  • In version 6.8.4 it started using a “modern style” for the save dialog. (What this means, I don’t know) You have to manually add the extension or (do what I’ve done) revert back to using v6.8.3. Many users have run into this :(



  • Thank you!!! I thought I was going completely bananas with this problem. I uninstalled, removed all Notepad++ files from my AppData folder and deleted all registry keys to do with Notepad++ in case it was a corrupt configuration, and it still did the same.

    I even recorded a video showing the issue ready to create a thread highlighting the issue.

    http://youtu.be/gBiBeddLQAU



  • THANK YOU for the answer. What a STUPID decision on Notepad ++ part. I am disappointed in them. I will just go back to 6.8.3. Is there any way to bring it to their attention to get this fixed for a future release?

    BTW I didn’t get an email notification of your reply? How do I set that in this msg board?
    Thanks.



  • @Justin-Morabito It is well known this is happening. I also hope it gets addressed.



  • Thanks for the help. I removed 6.8.4, downloaded 6.8.3 and installed it. Somehow in the process it upgraded to 6.8.6 which also is broken, so I did it again and when the installer tried to upgrade 6.8.3 to 6.8.6 I just cancelled it.

    All is well now. I don’t think that they are interested in fixing it if the issue still exists in 6.8.6. 8-(



  • So now I am running into a new little wrinkle. 8-) In version 6.8.3 when I type out something like an IP address, ++ wants to autofill the information with something other than what I need? Is there a way to turn those “suggestions” off?

    Also, I still haven’t figured out how to get notified via email when one of you all reply to this thread? Is that possible?

    Thanks for all of the great information.



  • Is there a way to turn those “suggestions” off?

    You mean Settings > Preferences > Auto-Complete > Enable auto-completion on each input?



  • Hi Justin, Sam and All

    Just look the original Don Ho’'s message, about it, from the link below :

    https://notepad-plus-plus.org/community/topic/10681/notepad-6-8-5-released

    However, many, many users complain about this new behaviour and it would be silly to be stopped with the 6.8.3 version because of that problem !

    So, may I suggest, Don, the possibility to include, in a future N++ version ( not necessary the next one ! ) a new setting, in the Preferences menu, to choose between the old and the new style of the save dialog ? Of course, if code’s changes are easy enough to implement !

    To my mind, this solution would satisfy every N++'s user :-)

    Best Regards,

    guy038



  • As usual, you all are awesome. Thanks for the help.



  • This is nonsense to call forcing a user to type “.txt” every time they save a new file “modern”… Windows 7 and 10 Explorer by default doesn’t even show the file extension; how does forcing a user to type it sync up with that?

    By default, a new Notepad++ user will save a text file just like they save it in Notepad, then next time go to open the file and Windows will ask them which program they want to open it in… even if they choose Notepad++, they can’t set it as a default because there’s no file extension!

    Did Microsoft determine this behavior as “modern”? If so, I don’t know why they’re contradicting themselves for the “modern” user. If not, I don’t know why Notepad++ is contradicting sense.


Log in to reply