Only one Theme in Style Configurator



  • Hi all,
    I am running Notepad++ 6.8.6 on Windows 10 as a non-Administrator user. I can use Notepad++ just fine in general, but I want to switch to a style other than the default.

    When I select Settings > Style Configurator, I only have the default option in the Themes list.

    If I run Notepad++ with the Run As Administrator option, then I have the full list of Themes to choose from.

    I don’t understand why the Themes require Admin access.

    Is there a way to run Notepad++ as a non-Administrator user on Windows 10 and still get access to the full list of Themes?

    Thanks!



  • Just to add to my notes above, when I run Notepad ++ as an Administrator, then the program cannot access my files in my own profile. Instead, it’s running under the local Administrator user’s profile.

    When that happens, Notepad++ can access the files under C:\users{admin}

    But I’m not logged into Windows as {admin}, I am logged in as {myself}. I need access to the files in C:\users{myself}.

    Thanks for any help, folks.



  • Did you install it as Admin? Perhaps copying the admin’s styles to your user and then correcting the file permissions will help.



  • Aha! Thanks for getting me to think more about this.

    I installed by way of a ninite.com package and so I think maybe it ran as Aministrator.

    I just now uninstalled, re-installed as myself and that fixed the issue.

    Thank you, Cees!



  • Run the Notepad++ installer as admin

    Next…
    Make sure Don’t use %APPDATA% is enabled

    This will enable themes for all users



  • Experienced the same problem today (Win10, installed logged in as administrator).

    Problem: User’s folder %appdata%\Notepad++\ does not contain folder themes.

    Solution: Copy the folder themes from administrator’s %appdata%\Notepad++\ and restart notepad++


Log in to reply