NPP EXEC - command line wrong

  • Hey there,
    I’ve tried to work on notepad with a text file and now I need to analyze it (with perl, needed scripts are provided).
    I have this command line:
    SET OUTFILE = C:\Users\Lisa\Desktop\UNi\WS1516\CT\output1.txt
    CMD /C

    all the paths are right, I tried several different options, but they actually should work.
    but then I get an error message saying:SET: OUTFILE = C:\Users\Lisa\Desktop\CT.txt
    $(OUTFILE) = C:\Users\Lisa\Desktop\CT.txt
    CMD /C
    Process started >>>
    <<< Process finished. (Exit code 0)
    CreateProcess() failed with error code 2:
    Das System kann die angegebene Datei nicht finden. (The system is not able to find the document)

    CON_SAVETO: C:\Users\Lisa\Desktop\CT.txt

    • OK, 826 bytes have been written to “C:\Users\Lisa\Desktop\CT.txt”
      NPP_OPEN: C:\Users\Lisa\Desktop\CT.txt
      ================ READY ================

    I am not sure how to solve this problem and I’m really desperate. Can anyone help me?

    Kind regards,

  • It looks like you do not have “CMD /C” and the PERL command on the same line.

    I think you have to do it like:

    cmd /c c:\perl\dwimperl\perl\bin\perl.exe c:\user...

  • Hello Lisa Nux,

    there are several issues here.

    First line sets an variable OUTFILE to C:\Users\Lisa\Desktop\UNi\WS1516\CT\output1.txt
    but the output states that it is OUTFILE = C:\Users\Lisa\Desktop\CT.txt ??

    Second line you open a command prompt with switch /C, which means cmd should terminate
    after command has been executed but you do not provide an command.

    Third line should execute perl with first parameter being the script which should get executed
    but, at least what you’ve provided, there is a space between \CT\ and PG_SCRIPTS… so perl
    cannot execute the script. Maybe that’s the source of the issue.

    and in this line

    there isn’t a space between PERL.EXE and C:\USER…


Log in to reply