Unicode character displayed as an empty box.



  • Symbol ‘⛓’ within "UTF-8-BOM’ document shows up as an empty box.
    Symbol is displayed properly when I open that document with Windows’ Notepad.

    I have Windows 8; Notepad++ v.6.8.2.



  • Hello SlavMFM,

    I’ might be wrong but isn’t the font responsbile to display this properly?
    If using standard windows notepad can you double check that notepad++
    is using the same font (Settings->Style Configurator)?

    Cheers
    Claudia



  • Hello SlavMFM,

    Your character, part of the Miscellaneous Symbols Unicode block, is the Unicode CHAINS character, of code-point \x{26D3} ).

    See, to that purpose, the PDF file, below :

    http://www.unicode.org/charts/PDF/U2600.pdf

    It’s a symbol that means : “Tyre chains required” ! Unfortunately, very, very few fonts can correctly display that character, and generally speaking, the Miscellaneous Symbols Unicode block :-((

    The only one, that I can think of, is the EversonMono font ( though not exactly, a monospaced font ) which can display the 256 characters of the Miscellaneous Symbols block. You can download it from the link below :

    http://www.evertype.com/emono/evermono.zip

    Even, the Arial Unicode MS or the Code2000 fonts, can’t display this specific character, although they, both, are able to display, respectively, 106 and 183, out of the 256 characters of the Miscellaneous Symbols block.

    The fonts, I’m referring of, are listed in the table, below :

    EversonMono           v7.000      Everson Mono.ttf       4411 Ko       9671 Glyphs       9643 Characters       97 Blocks
    Arial Unicode MS      v1.01       ArialUni.ttf          22731 Ko      50377 Glyphs      38917 Characters       65 Blocks
    Code2000              v1.171      Code2000.ttf           8181 Ko      63546 Glyphs      53068 Characters      118 Blocks
    

    So, I’m wondering how you were able to see the exact glyph of the \x{26D3} character ( Two chains ! ) with Microsoft Notepad ?! Just check the current Microsoft Notepad font used.

    Best regards

    guy038



  • My default Notepad++'s font is Courier New, but when I change it to Consolas (that which WindowsNotepad uses) problem still remains.
    WindowsNotepad displays symbols correctly with both Consolas and Courier New.

    Please look at what I’ve got:

    26a2 symbol displayed wrongfully at the first occurrence, but somehow properly at next two (caret is at Ln 6; Col 10):
    http://s4.postimg.org/6sfqos625/proper_last.png

    When I hit Tab:
    http://s29.postimg.org/ia40pu4ef/wrong_last.png

    When I hit Backspace 26a2 symbol is back to normal.



  • Hi, SlavMFM,

    First of all, I apologize for my late reply, but these last two weeks, I was busy with Christmas gifts and the change of my Internet and TV provider.

    Before, with our Power-Line networking installation, we usually got something like 14 Mb/s, as download speed and 0,8 Mb/s, as upload speed. Now, we currently have between 45 and 70 Mb/s as download speed and between 16 and 20 Mb/s , as upload speed :-) And, with a direct RJ45 network connection to the “Box”, we got between 270 Mb/s and 310 Mb/s, as download speed !

    Let’s back to our problem :

    I personally verified that the Courrier New and the Consolas fonts, even with their last versions, in the Windows 10 configuration of my son’s laptop, can’t display, either, the \x{26A2} character ( Doubled Female sign ) and the \x{26D3} character ( Two chains ) :-((

    So, I suppose that your operating system ( probably Windows 8 or 10 ) may use some fonts substitution process to correctly display these characters, in Microsoft Notepad, and sometimes, in Notepad++ !

    To that purpose, I advise you to read, carefully, that interesting Microsoft article on Fonts, below :

    https://msdn.microsoft.com/en-us/goglobal/bb688134

    Note : You may also read the six other pages, on that same topic :

    Page 1 Text Input, Output, and Display
    Page 2 Capitalization, Uppercasing, and Lowercasing
    Page 4 Input Language: Keyboards and IMEs
    Page 5 Line/Word Breaking
    Page 6 Complex Scripts Awareness
    Page 7 Console Globalization

    Also, look at the Wikipedia articles, below :

    https://en.wikipedia.org/wiki/Font_substitution

    https://en.wikipedia.org/wiki/Fallback_font

    As for me, on my old Win XP laptop, these two characters, above, are NOT displayed, either, in Notepad and Notepad++

    But, if I use the Everson Mono font ( see my previous post ), they are, as well as all the other characters of the Miscellaneous Symbols Unicode block, correctly displayed, with the two editors !

    May be, these characters are correctly displayed, only if they are NOT surrounded with Control or EOL characters ?

    Good luck for your future searches, about fonts : it’s quite an huge domain to investigate !

    Cheers,

    guy038



  • I have a similar problem: I don’t see the correct UNICODE characters.
    I use to open a prompt window and issue the command dir > temp.bat *.EXT then open the temp.bat file with notepad++ in order to bach rename the file with extension EXT.
    After the last update (if I’m not wrong), when I open the temp.bat file, unicode chars à è ì ò ù (I’m Italian) are not showed properly.
    I noticed in the status bar DOS/WINDOWS and ANSI. I suppose that here I should see UTF-8. No matter how I try, when I open the temp.bat file, the format changes back to ANSI.

    Can anybody help me?
    thanks, Angelo



  • At least my problem has a solution: in order to use UNICODE, open the prompt shell with CMD /U e not only with CMD.



  • Hello Angelo,

    In a prompt DOS window, your can know what is the current encoding : just type the command chcp and valid with the enter key. You probably use the codepage 850 ( OEM Multilingual Latin 1 ). Refer to the link, below :

    https://msdn.microsoft.com/en-us/goglobal/cc305160

    Of course, once your .bat file, opened in Notepad++, the accentuated characters, with code-point > \x{7f}, are wrongly displayed, because, Notepad++, use the default Microsoft ANSI codepage ( probably Windows-1252, as on my French configuration ! ). Refer to the link, below :

    https://msdn.microsoft.com/en-us/goglobal/cc305145

    You can, also, see that list, with the menu option Edit - Character Panel

    Remember that this ANSI code-page is the default codepage used, for all your NON Unicode programs, of your configuration.

    Therefore, the solution to get a well displayed .bat file, both, in N++ and with edit.com, in a DOS window, is to encode your file with the OEM 850 encoding with the menu option Encoding - Character sets - Western European - OEM 850
    ( if, of course, the chcp DOS command returned the number 850 )


    You may, also, convert, afterwards, this .bat file to the UTF-8 encoding, by using the menu option Encoding - Convert to UTF-8. However, this time, after opening it, with edit, in a DOS prompt window, it will be wrongly displayed too !

    Best Regards,

    guy038

    P.S. :

    BTW, I didn’t know the /U option of the DOS command cmd. Thanks for that tip :-))


Log in to reply