Double click selects whatever, but not what is mentioned to...



  • Hi all,

    Here’s the problem: the current version of NPP has weird behavior for double click and text selection.
    What I mean:
    The most current version of NPP on double click selects like this: http://prntscr.com/9hmf9l
    While the version 5.4.5 works like this: http://prntscr.com/9hmfpu

    Are there any ways to make 6th version select text correctly, like it was in 5.4.5?



  • Hello webdevpug,

    which language is selected. I assume that the word characters are expanded.
    I’ve tested with 6.8.7 and only LTIitem has been selected.
    Do you have python script installed if so, put following command in console
    and check the output while document is active.

    editor.getWordChars()
    

    Cheers
    Claudia



  • Hi, thanks for the answer.
    I’m using HTML language, but I’ve tried other languages with the same result.
    Here’s the result of python script output: http://prntscr.com/9hyucz



  • So here we are, something extended the wordchars. If you didn’t do it I assume a
    plugin to be responsible. May I ask you to start your notepad with the -noPlugin switch
    an recheck the behaviour? As you are using Python Script, could it be that your startup.py has
    something like

    editor.setWordChars(...
    

    in it?

    Cheers
    Claudia



  • Well, I’m not using python itself, it has been installed with some of the plugins. And I have strange thing noticed, I am using obsolete plugin - QuickText, when I insert some text with it, this thing happens, but after the document is saved and NPP is relaunched - this issue is gone…

    So it seems that QuickText is the reason. Is that possible to be solved or should I consider removing it/find an alternative?



  • @webdevpug
    from what I see development has been stopped since 2010 and developer
    mentioned that he has dropped support.
    From what I see, it is just a snippet tool therefore you’ve good chance to replace
    it with plugins like FingerText, snippet, SnippetPlus etc…

    Cheers
    Claudia



  • Thanks for help =)


Log in to reply