Disable Mouse Auto Movement



  • Is there a way to stop NPP from moving the mouse?

    It’s unbelievably annoying when I leave the find dialog open and minimize NPP. When I restore the window it moves the mouse over top the “Find Next” button. Oh dear sweet mother of Christ this pisses me off. I usually have (like any developer) a variety of applications that I switch between fairly often. So if I’m using NPP to reference some data while working in another program, I will minimize and restore quite often. And if I happen to have the find dialog open after restoring, I click that damn “Find Next” button instead of minimizing, and I have to scroll back to what I was referencing.

    It’s not just the find dialog that does this. When closing an unsaved document, I don’t want my mouse moved over the “Yes” button automatically. etc…

    It’s probably just because I’m a complete control freak, but this is a massive annoyance every day. I move around the screen and between documents rapidly and I don’t like losing track of my mouse ever few minutes. The dialog(s) can wait for me to be ready, and I will click a button when I damn well please after moving the mouse myself!

    Please tell me if there is a way to stop this!!



  • Hello jgjake2,

    you can’t blame npp for this rather your mouse properties settings.
    Check Pointer Options -> Snap to
    I assume this has been enabled(checked).

    Cheers
    Claudia