Encoding [§ gets big5 encoding



  • Hi!

    With the recent version, 6.8.8 we have a problem.
    My company has a (legacy) windows application which has config files with an application specific macro language.
    And that macro language has some special characters for formulas, like = [ ] etc
    they are all in the ascii codes < 127, but we also have the section/paragraph sign §
    Which is (dec) code 0167 in windows 1252 (and iso 8859-1) and (dec) 0254 in (DOS) extended ascii. Especially the combination [§ seems to “confuse” Notepad++ because then it sets the encoding/character set to Chinese big5.
    Which is at least very annoying and also dangerous if you start editing and dont notice that the encoding is wrong. We har already messed up files because of this, :)
    In previous versions (6.5.4 at least) it DOESN’T have this behaviour.

    Is there some way to make both us (Swedes) and chinese happy? :-)

    Regards
    /Thomas Åberg



  • Hello Thomas,

    To avoid a wrong automatic encoding, on starting N++ / selecting your file, I advice you to UNCKECK the option Autodetect character encoding in menu Settings - Preferences… - MISC. Just close and re-open N++. You shouldn’t have any trouble :-)

    Indeed, if this option is set, Notepad++ may decide of an exotic encoding, if some combinations of some characters appear at the beginning of a file ! Unfortunately, I have not been able to find out all these combinations, yet :-((

    Best Regards,

    guy038



  • Ahh…!
    That solved it, Big thanks!
    A bit embarassed :-$ that it was so easy.
    But i blame that todays programs are getting so big and featureful that “noone” can keep track of everything ;-)

    Best Regards
    /Thomas Åberg



  • @guy038 said:

    Hello Thomas,

    To avoid a wrong automatic encoding, on starting N++ / selecting your file, I advice you to UNCKECK the option Autodetect character encoding in menu Settings - Preferences… - MISC. Just close and re-open N++. You shouldn’t have any trouble :-)

    Indeed, if this option is set, Notepad++ may decide of an exotic encoding, if some combinations of some characters appear at the beginning of a file ! Unfortunately, I haven’t been able to find out all these combinations, yet :-((

    Best Regards,

    guy038

    Solved my issues as well. Thanks a lot:)



  • same here, thanks a lot!


Log in to reply