Notepad++ crashes when I try to connect via SFTP, but FTP works fine for some reason. v 6.8.8



  • Notepad++ has been crashing everytime I try to connect with SFTP the past few days. FTP works fine. I tried uninstalling and re-installing notepad++ but I am getting the same errors.
    Does anyone know a way to fix this?
    Thanks :P



  • Hello Roger-Knapp,

    I assume you are using NppFTP, correct?
    I did a quick test and it worked.

    Connecting
    [SFTP] Host key accepted
    [SFTP] Successfully authenticated
    Connected

    Is this the first time you tried sftp or was it working previously?
    If you already used it successfully did you do any changes in regards
    to npp and NppFTP? Any other changes which might be of interest?

    I used npp6.8.8 together with NppFTP v0.26.3 on windows 7 x64.
    But there is already a newer version v0.26.5 on github available.

    Cheers
    Claudia



  • Claudia,
    Thanks for the answer. Yes I am using NppFTP. I have connected with the exact same SFTP info previously and it was working fine for weeks (I just set up SFTP recently).
    The error message I am getting in the NppFTP Output box reads:

    [NppFTP] Everything initialized
    Connecting
    [SFTP] Host Key accepted

    Then I get a crash :<

    I haven’t made any changes to my npp configuration at all, and the NppFTP version is 0.26.3, on windows 10. I will take a look at the new NppFTP version out and see if that works.



  • I tried out the 0.26.5 and I am getting the same problem :<



  • I tested it with windows 10 x64 and it worked but you already said that it was working before.
    Do you have any entry in the eventviewer regarding npp?
    Do you use additional plugins, maybe there is a coincident with another one?
    Do you have local or appdata config? If appdata has been choosen during install,
    maybe worth trying renaming the notepad++ directory and restart npp.

    Cheers
    Claudia



  • hello,
    I’ve the same trouble since I updated NppFTP to 00.26.3 (Notepad++ v6.8.8 Build time : Dec 10 2015 - 01:11:37).
    Exception :
    code : 0xC0000005
    type : access violation
    exception address : 0x764243F9

    hope this pb will be soon resolved with a new plugin release …
    Somebody know how to rollback this newest release ?



  • @Jean-Marc-Tifle

    did you see that I linked to a newer version?
    In reagrds to an older version see here

    Cheers
    Claudia



  • Claudia,
    Figured out what the problem was, I moved the location of my private key to another folder, and didn’t update the changes in my sftp config. Silly me :<



  • Hello Roger,

    thank you for reporting this, maybe this helps @Jean-Marc-Tifle to solve his problem as well.

    Thank you
    Claudia


Log in to reply