Tab and Help screen font size too big - Windows 10



  • I just did a clean install of Windows 10. I’m having an issue where the tab font and the Help screen font for Notepad++ are too big. All other fonts in the app are fine (menu bar, editor, etc.)

    I’m not sure if this has to do with the fact that I’m running on a high DPI display and it’s not scaling or if there is another issue. I’ve tried changing the override font in preferences, but that didn’t seem to help. No other apps exhibit this behavior.

    Any ideas?



  • Hello @Michael-Whitis,
    did you set some custom dpi values or increase the proportion value from 100 to 125 or 150%?

    Cheers
    Claudia



  • Claudia,

    Thanks for getting back to me. All of my screens are set to pre-defined values.

    My 3200x1800 laptop screen is set to 150%, and my external displays (when hooked up) are all set to 100%.

    It doesn’t seem to matter whether I’m using notepad++ directly on the laptop or on an external display. My thought was that maybe NPP is grabbing the 150% from the internal screen and not adjusting after the fact, or if there is another display instead. I frequently use my laptop closed and hooked to one or more external monitors.

    What’s strange is that it seems like only certain text is affected (the “Help” box and the menubar). All other text, including the editor text is fine.

    I am going to pull the npp source and see if I can find anything, but was hoping that someone might have seen this before.



  • Hello Michael,

    I’m pretty sure that there is/was an issue when using npp with different screen resolution but
    wasn’t unable to find it on the quick and there is an open issue
    for the general ui behaviour with high dpi displays.

    Cheers
    Claudia



  • I installed a fresh PC, with one screen having 200% scaling, the other one 100% scaling. I reset the scaling to 100%, but nodepad++ still uses a huge font for the tab headings.

    grabbed_20160731-145243

    The screenshot is taken at the screen never having other scaling values than 100%.

    Update: This is a similar screenshot as posted at https://github.com/notepad-plus-plus/notepad-plus-plus/issues/629#issuecomment-230694203

    screenshot



  • The issue is also discussed at http://superuser.com/q/934701/138868. The current work around is to use Settings -> Preferences -> General -> “Tab Bar” -> Uncheck “Reduce”


Log in to reply