Automatic backup not working properly



  • I usually have several Notepad++ tabs open at once. My computer has crashed 3 times over the last few months, and one of the files—the same one each time—gets replaced with “nulnulnul”. I made sure that “backup every 7 seconds” was on and working, but the backup directory now doesn’t contain a backup for the file that got replaced with “nulnulnul”. After the crash I double-checked my backup settings, they were still set to backup every 7 seconds, but now it doesn’t seem to be working at all, no backup files are being created or updated in the specified directory.

    I’m going to have to stop using Notepad++ if this isn’t fixed… really terrible. I’ve lost several weeks worth of notes.



  • Well there seem to be a misunderstanding what backup means and how it should be treaten.
    Backup is, in best case, a duplicate of a file and in worst case your original file without the changes of the last saving.
    That a backup file can be lost, as well as the original file, is possible. Many external influences can causing this.

    To use backup functionality, you normally would edit a file and save it when done, which would then update
    the original file. In case of a crash there is a minimal possibility that both files (original and backup) are open and
    get corrupted because operating system wasn’t able to close files properly.

    What you do seems to be working on temporary files always, so there is no backup functionality.

    Regarding the backup every 7 seconds.
    Of course, there must be made a decision how often a file should be backed up but one must keep in mind
    that shorten the time period means increasing the possibility that the file is open while crash happens.
    And if it happens that often I would say you have to start investigating what is causing the crash because
    next time it might be that the whole disc is damaged.

    Regarding backup functionality lost. Did you check the settings if they are still set?

    Cheers
    Claudia


Log in to reply