Iike 6.9 - but it changes auto-complete behaviour



  • Hi,
    1st of all I’d like to thank all NP++ developers for giving me/us such a heavy tool ! Congrats!

    Like the autocomplete feature because I’m a lazy typer :)
    before 6.9 it autocompleted " to “” and ’ to ‘’. In my installation this is gone - with presettings in autocomplete-tab (checked!).

    Pease bring this back to life again. thx.

    The “folder as workspace” function has some technical teethings too:

    • no translation to German (not a big deal as I’m sure this is a matter of days… )
    • drag&drop of folders to the npp window is very cool - please support this for links to my folders too !
    • please support the used symbols for the different file-types in the “Folder as Workspace”-list too
    • please do not automatically open any file for editing (it’s not of use for me to immediately open a jpg-file in npp for editing - possibly a “do you really want to edit .jpg file?” could be a solution

    Annother one is the unsupported HTML5-Tag <main>
    Where is a place to update/enhance the syntax highliting feature? Is there a community thread for these issues ?

    Thanks for reading and again: Great Tool !



  • Hello @Gerhard-Auinger,

    I do have quote and double quote completion. Maybe try uncheck it, restart npp,
    check it again or check config.xml

    <GUIConfig name="auto-insert" parentheses="yes" brackets="yes" curlyBrackets="yes" quotes="yes" doubleQuotes="yes" htmlXmlTag="no" />
    

    In regards to html5 tag main, if using html lexer <main> gets colored in blue.

    Cheers
    Claudia


Log in to reply