Drag-and-drop files not working in latest version 6.9



  • Hello,
    I’ve recently downloaded 6.9 version and tried to drap-drop files into Notepad++ (that’s the usual way I open files in Notepad++), but to my surprise, I am no more able to do so.
    Also, it was mentioned that “Folder as a workspace” feature is available from this release, but no luck. I am not able to open folder in Notepad++ by dragging them. Even using File menu -> open option also does not work in this case.

    Please help!
    Thanks,
    Pavi.



  • Ok, I think I got what is wrong here.
    If I open any file from disk and on that instance of Notepad++ if I try dragging-dropping folder/file, it works.
    However, if I have created a new file in Notepad++ and on that instance of Notepad++ if I try to drag-drop a file/folder, it does not open.

    Is it a bug or feature ???



  • This post is deleted!


  • @Pavi-Ghosh

    in regards to opening folders do you refer to this problem (reported and video created by Artur Hareson)?
    In general, with introduction of the folder as workspace functionality the current situation
    is that dropping a folder to npp add this folder to the folder as workspace treeview instead
    of opening each file as a document.

    Cheers
    Claudia



  • Hi Claudia,
    Thanks for your response.
    I understand that folder as workspace feature works by opening it as treeview. I dont expect all the files in the folder to open in npp.
    My problem is (as I also discovered and mentioned it in my 2nd post in this thread) that when you have unsaved files in npp and when you try to drop a file or folder into NPP, it wont open if its a file and wont show as treeview if its a folder.

    For example, I work on many unsaved files in NPP. Since NPP has the facility to open all the unsaved files back again when NPP is launched, I never feel the need to save explicitly those unsaved files. Now in such an instance of NPP where there are multiple unsaved files are open, if you try to drop a file or folder it wont open. You can try this for yourself.

    Hope I have explained myself clearly.
    Please address this problem. Thanks!



  • Hello @Pavi-Ghosh,

    ok, I enabled session snapshot and periodic update, create a couple of new … files and put
    some random content into it. Closed and restarted npp, temporary files still shown.
    Opened explorer and dragged and dropped files which all opened, dropped folders to
    the folder as workspace window - worked as well.
    One thing I know, which could explain your behaviour, is when using different elevation levels,
    like you started npp as administrator but explorer isn’t at that level.

    Cheers
    Claudia



  • Thanks Claudia for trying it yourself. Your analysis regarding privilege levels could be right.
    This morning I started NPP, which as usual, opened up with all the temp files (A BIG THANKS for this feature as well) and to my surprise, when I dragged a folder and Voila!, it opened (in treeview). Dropped a file and it opened as well.

    I hope that’s the only reason to which you attributed this problem.
    Highly appreciate your efforts.
    Thanks a lot!
    Pavi



  • Please, PLEASE !!! Make this absolutely ridiculous feature (in current realisation) is switchable to totally disable it and forgot about it as a nightmare. Till then i’ll stay on 6.8.



  • Yep. Make this this [censored] [censored] switchable to totally disable it and forgot about it as a nightmare.



  • Please! make this switchable, for now I went back to 6.8.8.



  • Seriously… 6 months is past and still no changes ? WTF !??



  • This post is deleted!

Log in to reply