Any way to return to the former Home/End key pressing behaviour ?



  • Hello!

    With the recent update of N++ (using version 6.9 Windows here), we have had this change, that when text wrapping is enabled, and long lines are spanned over several lines, with false line breaks, when we hit the Home or End keyboard keys, it takes us to the end of the current line, and not the end of the real line, much below.

    While I found it cool at first, I’m starting to realize it’s a pain in dayly use. I find myself hammering the Home or End keys every time I want to reach a real end of a line. I tried with a shortcut to turn text wrapping on and off, didn’t help much frankly.

    So, that leaves me wondering: would you know if there is a way to go back to how things were before, and have the Home and End keys once again move the cursor to the real end / start of the lines ?

    I searched around and couldn’t find it myself, but, hey, maybe - hopefully! - I’m mistaken, and there’s a way to alter this setting.

    Thank you very much if you can help! :)



  • Hello @Vania-Wodey,

    you could reassign the shortcut to the SCI_LINEEND message.
    To do so goto Settings->Shortcut Mapper->Scintilla Commands
    and add an shortcut to SCI_LINEEND (line 63).
    Currently SCI_LINEENDWRAP (line 68) is using END - either delete or use another shortcut.
    Home: SCI_HOME needs to be assigned, currently SCI_VCHOMEWRAP is using it.

    Cheers
    Claudia



  • I’m looking to get the Shift-End shortcut to select all wrapped lines, not just the end of the current line. I looked at your instructions here and compared settings with an earlier version I have. In my earlier version, Shift+End is assigned to “SCI_LINEENDEXTEND”, and in this version 6.9, that one isn’t on there. But there are two entries for “SCI_LINEENDWRAPEXTEND”…which makes me wonder if maybe the “SCI_LINEENDEXTEND” might have been mistakenly left out? I tried assigning Shift+End to a few others but I couldn’t get it to work.

    Thanks, Eric



  • Hello Eric,

    you’re absolutly right. An update to parameters.cpp has brought up this behaviour.

    ->{TEXT("SCI_LINEENDWRAPEXTEND"),       SCI_LINEENDWRAPEXTEND,       false, false, true,  VK_END,      0},
    {TEXT("SCI_LINEENDRECTEXTEND"),       SCI_LINEENDRECTEXTEND,       false, true,  true,  VK_END,      0},
    {TEXT("SCI_LINEENDDISPLAY"),          SCI_LINEENDDISPLAY,          false, true,  false, VK_END,      0},
    {TEXT("SCI_LINEENDDISPLAYEXTEND"),    SCI_LINEENDDISPLAYEXTEND,    false, false, false, 0,           0},
    {TEXT("SCI_LINEENDWRAP"),             SCI_LINEENDWRAP,             false, false, false, VK_END,      0},
    ->{TEXT("SCI_LINEENDWRAPEXTEND"),       SCI_LINEENDWRAPEXTEND,       false, false, false, 0,           0},
    

    The first one should be

    {TEXT("SCI_LINEENDEXTEND"),           SCI_LINEENDEXTEND,           false, false, true,  VK_END,      0},
    

    Will open an issue.

    Cheers
    Claudia



  • @Eric-Shurin issue 1612 has been opened.

    Cheers
    Claudia


Log in to reply