Installation of XML tools failed

  • I’ve tried installing the newest version of Notepad++ and adding the XML Plugin, but every time I try to install it I get this error - and nothing else. So I have absolutely no idea why it’s doing this.

    I even tried to install an older version of the plugin, version 5.6, just to see - but nope, same error.

    I’m using Windows Vista so that may be it, but honestly I have no idea.

    Doing a search on google for results hasn’t turned up anything useful at all - just a handful of threads with people saying they’ve had this same issue, and no solutions that I could find. I’ve come here hoping that someone will have the answer.

  • Hello @Phae-D,

    how did you install xml tools? Using Plugin Manager? Other way?


  • I tried using the plugin manager. I tried a few different things so I’ll list them all here.

    1. Tried installing XML plugin from plugin manager right after installing the program. Got the error message.
      Uninstalled it and re-installed.

    2. Tried updating the plugin manager and then installing XML Plugin using plugin manager again. Same error. Uninstalled it.

    3. Uninstalled an earlier version and repeated steps 1 and 2.

    4. Re-installed the newest version and tried manually placing the XML Plugin dll file as directed by the instructions that came with it (dll file in same folder as the NPP exe file, and there were a few other files to go elsewhere but I can’t recall at the time what it was).

    None of these methods worked. I’m at my wits end trying to figure out what the issue is.

  • Assuming you’ve downloaded the zip version from here.

    Everything from the ext_libs directory (within the zip file) needs to be copied to
    either the notepad++ installation directory OR if you used the %APPDATA% configuration then it needs to be placed to the %APPDATA%\Notepad++ directory.

    The same applies to the xmltools directory, which only has one file XMLTools.dll.
    If you used %APPDATA% configuration, than copy it to %APPDATA%\Notepad++\plugins, if not using it, than copy it to the plugins directory under notepad++ installation directory.

    If it still doesn’t work, may I ask you to post the debug->info (avaliable under ? menu)


Log in to reply