Notepad++ freezes upon opening a javascript file



  • Since v6.8.8 I’ve had a problem where if I open a javascript file in notepad++ it will freeze. I’ve had to downgrade to v6.8.6 on my work computer to workaround this issue, but now I’m experiencing the same issue on my other machine. Both machines had old installs that were upgraded to v6.8.8. I’ve completely uninstalled all my plugins, uninstalled and reinstalled notepad++ several times, deleted the AppData folder, used Revo Uninstaller but nothing I do will make v6.8.8 or newer not freeze when you open a JS file.

    I can recreate the issue every time on both machines quite easily.

    1. Make a blank text file.
    2. Add the following:
      {
      “foo”: 1,
      “bar”: false
      }
    3. Save the file as test.json
    4. Open it in notepad++ v6.8.8 or newer
    5. Go to “Language” -> “J” -> “JavaScript”
    6. Freeze


  • Hello @netbusiness,

    it has been reported that using user-configured tab settings for javascript can cause notepad to freeze.
    Could this be the case for you as well?
    To check this, open langs.xml with a different editor like e.g. notepad and search for “javascript.js”.
    In the same line, is there an entry called tabSettings= ?
    If so, delete it and restart npp.

    Cheers
    Claudia



  • Yep, that did it. So are you saying I can’t use custom tab settings for javascript now? Or is this a problem with the update installation?



  • Yes, looks like you can’t use custom tab setting for js currently.
    I did a test with various values and it always freezes regardless which value I chose.

    Cheers
    Claudia



  • @netbusiness
    fyi

    Cheers
    Claudia


Log in to reply