How do I disable the 'Delimiter' function in Notepad++?



  • Hey guys,

    I’ve a question about Notepad++'s delimiter settings. I can’t believe I’m the only one who experiences this.

    For those who don’t know, the delimiter function (Settings -> Delimiter) allows you to select all text between two characters. This is an option you cannot turn off, you can only give in the characters that should be used to select.

    Another function is the Multi-Editing settings (Settings -> Editing -> top right corner). I use this function a lot, for instance to change/copy/delete multiple variables/strings/etcetera. I can simply double-click a variable and I’ll have the variable selected.

    The problem is that they both use CTRL - doubleclick. This way, if I try to select content_id from $array[] = new Content((int)$field['content_id'], $language_id);, I end up selecting (int)$field['content_id'], $language_id because that’s what’s between the two default delimiters.

    True, I could technically just CTRL - click and drag, but I’m a very habitual guy, and I prefer double-clicking over clicking and dragging.

    Is there any way at all to disable this? Maybe even a little trick to make this functionality not being triggered?

    Thanks in advance!



  • Hello @Sean-de-Leeuw,

    what ybout providing chars you never use like the EOT char etc…?
    To do so, open character panel, double click on one of those chars,
    it gets inserted into the active document (show all symbols), copy it and paste
    it into the delimiter open close boxes. Should do the trick.

    Cheers
    Claudia



  • Hello, Sean de Leeuw,

    You may, also, simply delete the round brackets in Settings - Preferences - Delimiter, in order to disable this specific N++ feature !

    Best Regards,

    guy038



  • Hi @guy038,

    did you restart npp after deleting the chars? ;-)

    Cheers
    Claudia



  • Hi, Claudia,

    Sorry for my late reply, but I’m trying to take advantage of some nice days, on March, to end the 2016 winter ski season, after an awful beginning of season, without decent snow ! Today, I skied, on the 7-Laux domain, at about thirty minutes from Grenoble, with my daughter, her boy-friend and some friends of her. Just fine :-)) To be honest, I was a bit slower than all those young persons… But I didn’t lose them, anyway :-)

    Well, let’s go back to your question : I repeated the operation and, indeed, NO need to restart N++. ! I just closed the Preferences dialog. To end with, I put again the round brackets as delimiters and, immediately, the mouse gesture CTRL + Double Left click selects, again, all the text between these delimiters :-)

    My home configuration is Win XP SP3, with N++ v6.90, on local mode

    Cheers,

    guy038



  • Hi Guy,

    I’m so jealous - I even can’t remember how snow looks like ;-D
    Hope you had some wonderful days, well, it sounds like it was brilliant.

    Sorry, but I wasn’t clear enought - when I’m deleting the delimiter char, close it
    and test it, it works -> confirmed
    But, when restarting npp - changes are gone - default ( ) delimiters are in place again.

    Happens on XP, 7 and 10. - Tbh - I should have checked the source but didn’t do it yet.

    Cheers
    Claudia



  • Hi Claudia,

    Oh ! I’m not so good for testing :-(( I quite misunderstood your question : I should have restart N++ to confirm that the changes are permanent !

    So, I verified again and , unfortunately, the changes were gone, even if I chose the Allow in several lines option :-(

    Cheers,

    guy038

    P.S. :

    If, in the Config.xml file, with an OTHER editor than N++, I change this line :

    <GUIConfig name="delimiterSelection" leftmostDelimiter="40" rightmostDelimiter="41" delimiterSelectionOnEntireDocument="no" />
    

    by that one :

    <GUIConfig name="delimiterSelection" leftmostDelimiter="" rightmostDelimiter="" delimiterSelectionOnEntireDocument="no" />
    

    on opening Notepad++, again, the round brackets are still set as delimiters !


    Finally, Claudia, the first reply you gave to Sean de Leeuw, was, at usual, the right one :-) We just have to choose two control characters, usually absent, in classical text files, for instance :

    • The control character STX ( Start of TeXt ), with code \x02

    • The control character ETX ( End of TeXt ), with code \x03

    So, to inhibit the CTRL + Double-click feature of N++, just follow these few steps below :

    • With an OTHER editor than N++, open your active configuration file Config.xml

    • Change the line, below :

      <GUIConfig name=“delimiterSelection” leftmostDelimiter=“40” rightmostDelimiter=“41” delimiterSelectionOnEntireDocument=“no” />

    by that one :

    <GUIConfig name="delimiterSelection" leftmostDelimiter="02" rightmostDelimiter="03" delimiterSelectionOnEntireDocument="no" /> 
    
    • Save the changes of the Config.xml file

    • Restart Notepad++

    => You’ll notice the new displaying of the two new delimiters, in the Settings - Preferences… - Delimiters section

    => From now on, the CTRL + Double-click feature would work, ONLY for text between the STX and ETX control characters, that is quite rare, in real life !!



  • Hi Claudia and Guy,

    I like your ideas, but somehow I can’t find my config.xml file. I have a config.model.xml, but there’s no delimiterSelection tag in there… Can I just paste it in there?
    Or can I just find the STX and ETX characters in some menu where I can copy and paste them into the delimiter settings?

    Thanks!

    -Sean



  • Hi, Sean de Leeuw,

    I suppose that your N++ installation was a classical one, with the installer and not a local installation, with the .zip or the .7z archive ?

    If it’s your case, just type, in a DOS console windows, the command cd /d %appdata%\Roaming\Notepad++ and valid with the Enter key

    => You should be at the right location, where you’ll find, ( at least ) four configuration .XML files :

    • config.xml

    • shortcuts.xml

    • langs.xml

    • stylers.xml

    Remember to close N++ and open the config.xml file with an OTHER editor to make the changes


    You could, also, choose an alternate way, explained at the address :

    https://notepad-plus-plus.org/community/topic/11531/wierd-issue-with-notepad/5

    Cheers,

    guy038



  • Hi,

    That worked like a charm, thank you very much!


Log in to reply