N++ doesn't remember the settings on user's account



  • Hi,
    I install N++ on my account (with Admin password) and change the language, style etc. After restart the program it works without the changes, I’ve made.
    It happens on my Win10 and on my one of old XP. But on one of my XP it’s ok.
    Where is the problem?



  • Hello @Artur-Pabjańczyk,

    first you have to distinguish whether you did a local or the appdata installation.
    Local installation means, the configuration files are in the same directory where npp executable is,
    where as appdata uses, well guess, the %APPDATA% environment variable to store the plugins
    and configuration data. If you check the debug info (available in ? menu) you will see a line

    Local Conf mode : ON/OFF
    

    On = local config
    Off = %APPDATA%

    Redo the steps (only one like changing style is needed).
    Close npp.

    Next check if the configuration files have been changed.
    I would check if config.xml has an changed entry

    <GUIConfig name="stylerTheme" path="NAME_OF_YOUR_THEME" />
    

    If it doesn’t, (double check the other location) check your write permissions on that file and/or directory.

    To see, what’s really going on you could use procmon (sysinternals tool) to trace your modification.

    Cheers
    Claudia



  • Thanks. I"ll try it in a few days.



  • If the software when editing can switch to the transparent background theme is also useful.



  • During the installation I haven’t checked the first option: “Don’t use %APPDATA%; Enable this … . Check it if you use N++ in an USB device.” The “USB” misleaded me. Thank you for help.



  • Am I correct to say, that problem has been solved by using local installation?

    Cheers
    Claudia



  • Local You mean on my “non-admin” profile?
    I had a problem using local installation without this option, and now it works after local installation with this option.
    Local Conf mode is OFF.



  • Local in regars to the npp installation does mean configuration data, plugins and notepad.exe in one directory.
    So has nothing to do with your non-admin profile.

    I’ve asked the question because I wasn’t sure if your problem is solved or not.

    Cheers
    Claudia


Log in to reply