Compiling NP++ - Error compiling scintilla



  • I recently installed VS 2013 and I wanted to compile NP++. However, when I try to run “buildboost.bat” I run into the following issue (see below for error log).

    I think this issue comes from some bad environment variables, but unsure as I tries changing them to no avail.

    Would any of you know the problem behind these errors?

    Regards

    – ERROR LOG –


    Building tool to check boost version


    Microsoft ® Program Maintenance Utility Version 12.00.21005.1
    Copyright © Microsoft Corporation. All rights reserved.

        del /q .\bin\getboostver.exe
    

    Could Not Find C:\Work\01.Programs\01.NotePad++\01.SourceCode\6.9-notepad-plus-plus-master\scintilla\boostregex\bin\getboostver.exe
    cl -O1 -MT -DNDEBUG -GL -nologo -IC:\Work\01.Programs\02.Boost\boost_1_55_0 getboostver.cpp /link -OPT:REF -LTCG -nologo KERNEL32.lib USER32.lib /OUT:.\bin\getboostver.exe
    getboostver.cpp
    getboostver.obj : error LNK2001: unresolved external symbol @__security_check_cookie@4
    getboostver.obj : error LNK2001: unresolved external symbol _printf
    LINK : error LNK2001: unresolved external symbol _mainCRTStartup
    .\bin\getboostver.exe : fatal error LNK1120: 3 unresolved externals
    NMAKE : fatal error U1077: ‘“C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\bin\cl.EXE”’ : return code ‘0x2’
    Stop.


    ** ERROR building getboostver.exe
    ** Please see the error messages above, and post as much as you can to the
    ** Notepad++ Open Discussion forum
    ** http://sourceforge.net/projects/notepad-plus/forums/forum/331753



  • Hello @Nyrotagor,

    you ran this within developer command prompt, didn’t you?

    Did you follow the steps described here?

    Cheers
    Claudia



  • Oh, I didn’t try compiling within the developer command prompt. Now it works. On to the next step. Hope the rest goes to plan :)

    Thank you for the help on this matter.