Notepad++ doensn't start when doubleclicking files

  • After upgrading from Win 7 to Win 10, Notepad++ doesn’t start when doubleclicking associated files. Nothing happens except the windows “wait circle” is visable a few seconds.
    But if Notepad++ is already started, clicked files will be opened as expected.

    I tried to solve the problem by removing the installed old portable version and then install V6.9.1 portable, but the problem didn’t go away.

    Rightclicking a file and choose “Open” --> same behavior
    Rightclicking a file and choose “Open with” (notepad++) --> same behavior.

    Rightclicking a file and choose “SendTo” (notepad++) --> works

  • Hello @Mats,

    entry in SendTo has been created by you hasn’t it?
    Where does SendTo point? Which path and executable?

    If you open registry editor and check a file extension which doesn’t open npp.


    What is listed under openwithlist, userchoice and openwithprogids?

    Do you know that you can create an shell entry which would call npp directly instead of using
    the application dialog and find the appropriate app?


    Create a string value and put in something line

    D:\PATH_TO_NPP\notepad++.exe %1


  • Hello Claudia

    Yes, the SendTo entry was created by me and works fine, pointing to D:\PGM\Notepad++\notepad++.exe
    I tried to create an shell entry as you suggested, with the same path, and it works.

    In the registry, it’s different depending on which associated extension you look at:
    Under openwithlist .txt:
    a notepad++.exe
    b abc
    f notepad++.exe
    MRUList afebcd

    b a

    a notepad++.exe
    MRUList a

    Under openwithprogids .txt
    Notepad++_file (binaryvalue with null-length)
    txtfile (binaryvalue with null-length)

    xmlfile (binaryvalue with null-length)

    Notepad++_file (binaryvalue with null-length)

    I’m running a swedish version, so I did a translation if you think the value “binaryvalue with null-length” is strange. The value I see is “(binärvärde med nollängd)”

    Under UserChoise .txt
    Hash YoCvzaGlx4g=
    ProgId Notepad++_file

    Hash JwUoPW3BLOY=
    ProgId xmlfile

    .log UserChoise don’t exists

    I did a test with .txt and changed the value “a” to full path of notepad++, but it’s still the same, notepad++ isn’t started.

  • Hello Mats,

    binaryvalue with null-length is ok, more strange sounds binärvärde med nollängd to me ;-))

    If you have a progid of Notepad++_file then there is a need to have the same key under software classes.
    Is this the case? Something like

    and default needs to point to your npp installation.


  • Hello Claudia!

    [HKEY_CURRENT_USER\Software\Classes\Notepad++_file] doesn’t exist.

    Inside npp, I removed npp association with .txt, .log & .xml, then I added it again. After that, .txt and .log works but not .xml!
    Then I rightclicked a .xml file, choosed “open with” and select always use npp. After that, .xml also works. I did try that before, the new thing was to remove and add association in npp first.
    So the problem is solved, but there is still a lot of questions how this could happend.
    Thanks for helping me.

Log in to reply