Disable mouse 4 shortcut to switch tabs?



  • Hey guys.

    Is there a way to remove document switching when using the Mouse 4 button? I’ve checked the shortcut settings and I can’t see any mouse references in there at all.

    Searched google with no avail, I’ve had to resort to going into multiinstance mode.

    Cheers,
    Scott



  • Hello Scott,

    afaik mouse configuration can’t be modified using npp.
    But normally your multi button mouse comes with additional software which
    can/should be used to configure what button executes which action.

    If this isn’t the case, check if Control panel->mouse give you the ability to reconfigure.
    What has been assigned to the button in question?
    Do you mind reconfiguring it or is it needed for other application?

    Cheers
    Claudia



  • Hi Claudia,

    I use a program similar to Skype called Teamspeak, my push to talk button is Mouse 4. What tends to be happening is i’m doing some programming and talking on Teamspeak, talking changes tab windows.

    As I said in my first post, I’ve just turned on multi instance mode which fixed it, but it would still be nice to have my tabs back.

    Cheers,
    Scott



  • Hi Scott,

    but it would still be nice to have my tabs back.

    That’s why I asked for the configuration of your buttons to see if we have a chance to reconfigure it.
    Either on mouse’s side or on npp’s side.
    To switch tabs, npp uses normally CTRL+W but it could be that other “SIGNALS (??!!)” are interpreted
    as well. So without knowing what your mouse button click does I could only propose, try reconfigure the
    CTRL+W (shortcut mapper) to something else.

    Cheers
    Claudia



  • Hi Scott, I need to correct myself, it isn’t CTRL+W which switches Tab,
    it is CTRL+PageUp and CTRL+PageDown.

    Sorry for confusion.

    Cheers
    Claudia



  • I have the exact same problem since I did a fresh Windows 10 install. I unmapped al the shortcuts in Shortcut Mapper that contain the word “tab” but I still have the same problem. MB4 switches tabs left, MB5 switches tabs right. I use X-Mouse-button-control to assign MB4 with Copy and MB5 with Paste. It is working in all apps except for Notepad++, I need it alot in Notepad++…

    What can I do?



  • @kleajmp said:

    I use X-Mouse-button-control

    Sorry, not an expert on extra-buttoned mouses. As far as I know, the Win32 API interface defines left, right, and middle-click sequences, but doesn’t have special sequences for the extra mouse buttons (I could be wrong). So I don’t know that there’s anything for Notepad++ to do. I have always been under the impression that it’s up to the mouse’s driver / configuration software (I assume that’s what X-Mouse-button-control is) to convert the special signals it receives from the mouse to indicate MB4 or MB5, and translate that into keyboard-equivalent sequences to send to the app.

    It is working in all apps except for Notepad++

    Sorry, I don’t know why, unless the mouse software has some app-specific config that wasn’t set right for Notepad++.

    Oh, another thought:

    X-Mouse-button-control

    Does that X- prefix mean that you’re in a linuxy x-windows environment, with something like WINE to make Notepad++ run? Maybe such an environment handles extra-button mouses differently than a pure-Windows environment.

    Once again, not an expert; just sharing my ideas.



  • Thanks for your reply,
    the strange thing is that in my previous Windows installation (not a a linuxy x-windows environment just a gpt windows installation) it was working perfectly.

    So my thoughts where maybe because I reinstalled Notepad++ there was maybe a new feature or setting that possibly caused the problem?

    I also tried a workaround someone used with the same problem but for a game:
    https://steamcommunity.com/app/91310/discussions/0/792924412381617739/
    But that is not working, my extra mouse buttons keep on changing tabs in Notepad++.

    Anything else you can suggest me?



  • @kleajmp said:

    I reinstalled Notepad++ t

    maybe it’s the change in the new version of scintilla…

    try downloading the zip version of 7.6.6, which is the last version before the scintilla upgrade. unzip it into a known directory (maybe on your desktop or similar), and run notepad++ from there instead of your normal shortcut/association. If that version works, then uninstall your new installation, and install the 7.6.6 install version instead. Also, if that’s the case, let us know, because it will probably require a bug report.


Log in to reply