Display asian characters (Japanese, Korean, Chinese,...) on Open file



  • Using the ANSI encoding; I can write Asian characters just fine and as long as I do not close the file I can close the program and next time at restart the characters will display correctly.

    However if I close the file after saving, then try to open it again -either right after or after a software re/start- I will see “?” or square symbols instead.

    How can I save the file so that after re-opening it the Asian characters will display correctly?



  • Hello @Zsombor-V

    I assume that autodetect character encoding is enabled.
    I would give it a try to check it with disabled auto-detection

    Settings->Preferences->Misc
    uncheck autodetect character encoding

    Cheers
    Claudia



  • I’m not really an expert on this stuff, but I was using Notepad++ to edit Japanese text until yesterday. However, following a Windows update, all Japanese next now displays in Notepad++ as boxes. I’ve tried unchecking autodetect, closing the program, reopening, etc., and nothing has changed. Can anyone help?



  • As an addendum, unchecking/rechecking the autodetect encode doesn’t work, switching between encodes doesn’t work (ANSI turns boxes into random symbols), changing the display font in the style configurator doesn’t work. Japanese text displays properly in Windows Notepad, and I’m running Win10 Pro.



  • @hoihoi-san

    If it works within MS Notepad than check which Font it is using.
    Set the same font in npp (Settings->Style Configurator) and make
    sure you set enable global font ( just to be sure ).

    If it doesn’t work, can you provide that file,
    in addition a screenshot of your Style Configuration together
    with the problematic file.

    Cheers
    Claudia



  • I followed what Claudia suggested and Voila, all the CJK two bytes characters are now properly shown. Try for example “Arial Unicode MS”…