Tab indent not showing in my log.txt file



  • I have a log file which I create using “t" as a tab to format the output of the log . When opened up in notepad++ 6.8.8 the tab indents are not showing where i have used the "t” character for tab spacing. I have ‘Show Indent Guide’ on. When I create a new text document the tab indent are working as they should. Is “`t” not recognized by notepad++ as a tab ?



  • Hello @Nic-Harding

    no, afaik there is no automatic “convert a `t to tab function”
    What you can do is to use find replace it your `t and replace it with \t.
    Note, you have to check Extended in search mode.

    Cheers
    Claudia



  • When viewing my log.txt file the (`t) characters are shown as tab spacings, i do not see the 't character. They are blank but just do not have those vertical indent guides visible.

    I changed my tab delimiter in my logging app to a (\t) now when viewed in notepad++ the actual \t is visible not a blank tab spacing??

    When I tried find and replace as you suggested using Extended mode it found nothing.

    So it looks like using `t as a tab delimiter does show as actual tabs in notepad++ but the indent guides are not visible/working.

    Any other ideas?



  • Sorry, being confused.

    When you open a new document and you press the tab key you see the tab sign —> , correct ?
    If you open your logfile you do have the tab spacing but not the sign —>, correct?
    If you zoom into the logfile as much as you can do you see dots instead?

    Cheers
    Claudia



  • When you open a new document and you press the tab key you see the tab sign —> , correct ?

    YES … but only if ‘View/Show Symbol/Show White Space and Tab’ has been selected, and if I have ShowIndentGuide on then I see the indent guide as well.

    If you open your logfile you do have the tab spacing but not the sign —>, correct?

    I have blank tab spacing, and same as above when ‘View/Show Symbol/Show White Space and Tab’ has been selected the ‘–>’ tab arrows show … but if turn on ShowIndentGuide there is no indent guide showing like in a new text document (above).

    If you zoom into the logfile as much as you can do you see dots instead?

    Zooming makes no difference, no indent guide dots appear.



  • Ahh, now I got it.
    Hmm, fonts may be a culprit but this wouldn’t explain why new doc show the line indent.
    Different languages selected? Maybe with different font settings?
    Maybe try to reset it.
    Settings->Style Configurator->Global Styles->Indent guideline style
    Change attributes and revert it. (Changes should appear immediately)

    Cheers
    Claudia



  • Both language’s = Normal Text.

    Settings->Style Configurator->Global Styles->Indent guideline style, change indent colours etc. on the new text doc. but no changes on the log.txt

    I created a new doc using win ‘notepad.exe’ with tabs, opened in notepad++ and the tab indent lines were visible.



  • In my ‘log.txt’ file if I press enter to create a new line (anywhere) then press tab a few times it does show the tab indent lines, but still not in the actual log data (which is tabbed).

    When i do a search + replace using \t (Extended) it does replace all the tabs with the replacement text.

    Im using AutoHotKey and the command FileAppend to create a log file, using t for the tab andn for a new line, strange that when my log is created I can not see the indent lines.



  • ok, when i use the following to add data to my log.txt:

    1. FileAppend, me tt TEST ttt NICttt`n, log.txt
      It tabs correctly but does not display any indent guides.

    2. FileAppend, tt TEST ttt NICttt`n, log.txt
      This shows the first 2 tabs “with indent guides” but the tabs after the word TEST do not show the indent guides.

    At the moment Not sure why the tabs after the text do not show the indent guides.



  • Looks like it was my understanding of how the ‘Indent Guides’ work.

    My log show the time/date first then some data:
    15:24:45.092 Mon, 18 Apr 2016 :: Exit complete!

    I just assumed that the ‘Indent Guides’ would show after the 2 colons “::” but they only appear if the tabs start from the very beginning of the line.

    So, is there a way to show ‘Tab Indent Guides’ in the middle of a line of text, as an example below:

    15:19:10.754 Mon, 18 Apr 2016 :: System_Boot()
    15:19:10.759 Mon, 18 Apr 2016 :: System_Power_On()
    15:19:10.776 Mon, 18 Apr 2016 :: TV_Power_On() : USBUIRT_SendIRPronto(TV_Power_On_Code)
    15:19:10.781 Mon, 18 Apr 2016 :: WMC_Open_RecordedTV()
    15:19:10.790 Mon, 18 Apr 2016 :: WMC already open.
    15:19:10.816 Mon, 18 Apr 2016 :: Win_Maximize()ahk_exe ehshell.exe
    15:19:10.946 Mon, 18 Apr 2016 :: WMC_RecordedTV()
    15:19:11.021 Mon, 18 Apr 2016 :: Turn_AMP_Off()
    15:19:11.043 Mon, 18 Apr 2016 :: Set AC3Config /remote /preset to ‘tv’
    15:19:11.046 Mon, 18 Apr 2016 :: Change audio output to [SAMSUNG-4]
    15:19:11.321 Mon, 18 Apr 2016 :: AMP_Off() : USBUIRT_SendIRPronto(AMP_Off_Code)
    15:19:11.343 Mon, 18 Apr 2016 :: Set AMP_Volume_Switch = False

    I would like to see the guides in the middle of a line… possible?



  • Afaik, this isn’t possible with npp natively.
    Would you mind show us visible what you try to achieve by, maybe using the pipe | and/or minus- or underscore_ chars?
    Maybe someone can think of an alternative.

    Cheers
    Claudia



  • Heres an example of using pipes and dashes:

    Mon, 18 Apr 2016 :: Process_Destroyed_gphoto()
    Mon, 18 Apr 2016 :: ----Set volume to 100%
    Mon, 18 Apr 2016 :: ----Win_Restore ahk_exe ehshell.exe
    Mon, 18 Apr 2016 :: ----|—Win_Focus ahk_exe ehshell.exe
    Mon, 18 Apr 2016 :: ----|—Process_Created_gphoto()
    Mon, 18 Apr 2016 :: ----|—|---test1
    Mon, 18 Apr 2016 :: ----|—|---test1
    Mon, 18 Apr 2016 :: ----|—|---test1
    Mon, 18 Apr 2016 :: ----|—|---|—test2
    Mon, 18 Apr 2016 :: ----|—|---|—test2
    Mon, 18 Apr 2016 :: ----|—|---|—test2
    Mon, 18 Apr 2016 :: ----|—Back to here
    Mon, 18 Apr 2016 :: ----|—Back to here
    Mon, 18 Apr 2016 :: ----Back to here

    Is it possible to show indent guides in the middle of a line where my tabs are??


Log in to reply