Network Drives no longer work with 6.9.1 update



  • Network Drives are no longer visible in the File Open view nor any other view I can think of to try opening files (eg New Workspace/Open Session). I had previously been using Notepad++ version 6.8 and was able to open files on my defined network drives without any problem.

    • I also tried getting the Explorer plugin but that couldn’t see the network drives either
    • I confirmed the drives are online and I can access + open the files from Windows Explorer
    • I also tried toggling on the “Show Hidden Files” but that didn’t work either.
    • I tried setting the program to always open in Administrator mode but that didn’t change anything
    • I tried uninstalling the most recent version and re-installing it to a new directory (I think it may have kept some of my App Data, not sure though)

    There was a similar topic 6 months ago where the “solution” was to uninstall, manually remove all registry entries for NP++, then reinstall but that sounds like a pain for most users to do: https://notepad-plus-plus.org/community/topic/10791/notepad-v6-8-6-fails-to-open-files-from-shared-network-drives
    Since that solution is outside the scope of what most users may know how to do, I think this should be considered a bug and fixed in the next dot release.

    Any other suggestions?



  • Are you running NP++ with elevated privileges (aka “as Administrator”)? You can tell if it says “[Administrator]” in the Title Bar of NP++ Window. If so try running in normal Session or recreate your mappings from an elevated command prompt.



  • @gerdb42 yeah I mentioned that in my 4th bullet point, but to answer your other question yes I’ve tried both Admin and Non Admin mode. For admin, I enabled the force Administrator mode option from the executable file properties which ensures the program opens in Administrator mode and even that didn’t work. I confirmed it ran in Admin mode because it said “Administrator” in the top titlebar like you said. Switching Admin mode off didn’t work either.

    Here’s output of the “Debug Info” while running admin mode:
    Notepad++ v6.9.1
    Build time : Mar 28 2016 - 19:48:40
    Path : C:\Program Files (x86)\Notepad++\6.9.1\Notepad++\notepad++.exe
    Admin mode : ON
    Local Conf mode : OFF
    OS : Windows 10
    Plugins : none

    Thanks for the help!
    Pete



  • @gerdb42 I take that back. I just noticed that even when I didn’t have the “Force Administrator Mode” turned on it was still opening in Admin mode. I checked the box, applied the settings, and also enabled Comparability mode for Windows 8 just for the heck of it, and then unchecked admin mode and now the Network Drives are showing up again!


    Solution:
    If anyone else is having this problem I would suggest trying this first because it sure does beat going through the Registry line by line and deleting the entries. If you are having the problem, this is what did it for me:

    1. Enable the “Force Administrator mode”, apply the settings
    2. Uncheck the Force Administrator mode, apply the settings
    3. If those two steps don’t work then try also forcing Compatibility Mode for Windows 8, applying the settings, and re-launching NP++ in NON-administrator mode and see if you’re able to see your network drives again.

    I’m guessing this would only be a problem for people upgrading who may have had certain privileges set prior to the upgrade but I can’t remember whether or not that was the case for me.

    @gerdb42 Is there a way to set this topic as solved so people don’t waste their time reading through it? I appreciate your help in getting this fixed! Thanks a million

    Pete


Log in to reply