This ANSI plugin is not compatible with your Unicode Notepad++



  • I get the error message described in the title line each time I launch Notepad++. The following plugins seem to be at issue;
    7z.dll,
    CSScriptLibrary.dll,
    ICSharpCode.NRefactory.CSharp.dll, and
    Mono.Cecil.dll
    I assume these plugins are installed with the application as the only plugin I have loaded explicitly is Rainlexer.dll. The only possible exception is something called Wakatime.dll. I received an email thanking me for downloading it, and it does appear in my list of plugins, although I have no idea what it is or does, and did not intentionally download it.

    Can I simply delete the offending .dll files?

    Thank you,
    Mark R Russell



  • Most of those sound like some other type of DLL not meant to be loaded as a plugin.

    I assume these plugins are installed with the application

    Nope. It’s possible some other plugin (e.g. Wakatime.dll) installed them.

    Can I simply delete the offending .dll files?

    In theory yes. Unless for some reason Rainlexer.dll needs them.


Log in to reply