Insertion of special characters



  • If I want to insert a special character, I use the [Alt] key plus the Numpad. E. g., a dash is represented by [Alt]+[0151]. (I found no way to do easier.) However, Notepad++ always puts the character at the end of the current line, regardless of where I set the cursor in the line. Even a macro shows the same behavior. This is very annoying, for in most cases I have to cut this character and paste it to the position I want it to, thus slowing down my work.
    THis is a behavior I noticed in all Notepad++ releases over the years.



  • Yes, it’s bit annoying. But this only happens when you operate your numpad in cursor-mode. If you switch to number-mode (NumLock active) the cursor remains at its position. Or reassign Scintilla Command SCI_LINEENDDISPLAY from Alt-End to something else.



  • Thank you for your help. I reassigned the command to Alt-Shift-End and it works. The alternative option with NumLock active as well.


Log in to reply