Gap between line numbers and textarea depending on Language menu setting



  • I recently noticed that some of the Language Menu selections add an extra border/gap between the line number section and the actual text, and others do not. For example, a plain .txt file or “Batch” or “Makefile” do not have this gap, but others like “C” and “Perl” and “HTML” do have this gap. It appears all my User Defined Languages do have this extra gap, as well.

    NoGap

    WithGap

    So, I have a few questions:

    1. Can I change this setting on a per-language basis (and if so, how)? For example, could I turn off the gap for “HTML”, or could I turn on the gap for “Makefile”?
    2. Can I change this setting on my User-Defined Languages?

    (I was about to ask a third question: “once you’ve overridden a .txt file’s Language, how do you get back to plain text (no syntax highlighting)”. But I read thru the entire Language list and found that “Normal Text” does it.)



  • Hint: fold indicators are shown in this column when applicable.



  • Thanks. That would’ve been obvious if I’d been starting from actual C or Perl with folding. Since I was starting from a Normal Text file and going the other way, it wasn’t as obvious. :-)

    So I’ve got a UDL that has no folding defined, but it still shows up with the gap. Is there a way to turn off the gap when the UDL doesn’t have any folds? Or am I just missing another tab that includes folding settings, other than “Folder & Default”? Okay, I looked, and I see “Comment & Number” has the (_) Allow folding of comments, but that’s turned off on my UDL as well.


Log in to reply