Windows notepad corrupted by notepad++



  • Ever since I installed notepad++, the original notepad that came with Windows doesn’t function. I executed the notepad.exe in Windows and also tried in System32, both open notepad++. I copied an authentic windows notepad.exe from another pc, it worked for a while, opening txt in notepad proper. Then, it stopped working all together. I made a new copy of the Windows nptepad, but it doesn’t work, nothing happens. Somehow, notepad++ took over the notepad functions completely, and replaced “notepad.exe” with it’s own version.

    How can I restore the original notepad and get rid of this notepad++ virus???

    thanks



  • @Mike-Frost

    afaik npp installer doesn’t do that, some(one|thing) else must be responsible.
    The answer about how to revert it isn’t easy as we don’t know what was done.
    I assume, from what you’ve told, that the registry needs to be modified but
    the steps, which need to be done, depend on the windows version you use.
    And you should know, that modifying the registry could lead to a non-bootable
    windows. So be sure you know what to do and back up your stuff.

    Cheers
    Claudia



  • @Mike-Frost ,

    Where did you download / install Notepad++ from? Because if you didn’t download it from https://notepad-plus-plus.org/, you may have found a virus-infected copy (from the “it worked for a while… then it stopped working all together” description). If you didn’t download Notepad++ from its own domain, I’d highly recommend running a virus checker. Once you’re certain you are virus free:

    What happens if you run notepad.exe directly? Try it by multiple methods (close all notepad.exe windows between each step to avoid confusion): these should all open up the traditional Windows Notepad:

    1. [Win]+Rnotepad.exe: this runs whichever notepad.exe is first in your path. To verify where notepad.exe is running from:
      a. Ctrl+Shift+ESC → Processes (Win7) or Details (Win8, Win10): this lists the processes; you should be able to find notepad.exe in the list. If you cannot, you might need to ☑ Show processes from all users (or similar verbiage).
      b. Right click on notepad.exeOpen File Location: that will open a Windows Explorer in the directory where notepad.exe lives. It will usually be one of the directories I mention below.
    2. %WINDIR% (often C:\Windows)
      a. Windows Explorer → Navigate to %WINDIR% (often C:\Windows; you should be able to click in Explorer’s Location Bar and just type %WINDIR% with both of the percents signs) and double-click notepad.exe there
      b. [Win]+R%WINDIR%\notepad.exe
    3. %WINDIR%\System32 (often C:\Windows\System32)
      a. Windows Explorer → Navigate to %WINDIR%\System32 and double-click notepad.exe there
      b. [Win]+R%WINDIR%\System32\notepad.exe
      c. On a 64bit windows, this should open the 64bit notepad
    4. If you’re on a 64bit OS, you might want to also check the 32bit version: %WINDIR%\SysWOW64 (often C:\Windows\SysWOW64)
      a. Windows Explorer → Navigate to %WINDIR%\SysWOW64 and double-click notepad.exe there
      b. [Win]+R%WINDIR%\SysWOW64\notepad.exe
      c. If you do the task manager check, Windows 7 shows notepad.exe *32 instead of just notepad.exe to indicate that it’s the 32bit version on a 64bit OS. (I think Windows 10 does something similar)

    All of those should run the normal Windows Notepad. If they do, then the problem isn’t with your notepad.exe executable.

    If the problem isn’t a virus, and isn’t a bad notepad.exe executable, then it’s probably your file association. As @Claudia-Frank said, it’s possible to fix file associations directly in the registry (which should only be done with the caveats she mentioned). But another way to fix it is to open Windows Explorer, find a .txt file, right click, Open With..., and Choose Default Program, then pick Notepad from that list (or browse to your known good copy from step 3, above), and ☑ Always use the selected program. (I used the Windows 7 terminology. I think Windows 8 and 10 have a similar sequence.)



  • To save a bit of time on section 1:

    [Win]+Rcmd.exe.
    Then type: where notepad.exe and look at the results. The first one in the list is the one it should execute first, but you can double check your path if you want:

    echo %PATH%.



  • @Mike-Frost
    It might be the Notepad Starter Plugin.

    Open Notepad++ -> Plugins -> Plugin Manager -> Check NotepadStarterPlugin -> Click Remove


Log in to reply