Extra space in begining of lines



  • When i use Language some space form the end of line goto start!

    1 How to disable this Language selection?
    Alt text
    2 How disable extra ugly space??
    Alt text

    Must be all inline
    Alt text



  • This post is deleted!


  • At first, I thought you were talking about the consistent space before each line, which is where the fold indicators go (as I learned a couple months ago ).

    But I then saw the extra space on a couple of lines. I don’t know what causes that…

    But to “unselect” a language, you choose Language > N > Normal Text:



  • its ONE line with “word wrap” mode on!



  • for example - text one line
    and mode “action script” (and some other do the same) + word wrap
    Alt text



  • From my experiment with sample text, word-wrap on, and Language = ActionScript:

    If you look closely, you can see the orange dot which indicates a space character (View > Show Symbol > Show Whitespace and Tab).

    So, it appears the WordWrap function works slightly differently with some languages, on how it decides whether to wrap the word plus the preceding space, or just the word. (it also may depend on what is highlighted or not, and what character(s) come before the space). It may be lexer dependent, or it may be some other bit of internal and/or scintilla code.

    So, to answer your original question#1 again: to turn off the Language setting for a given file, Language > N > Normal text. For #2, it appears to be language and/or lexer dependent, along with what characters form the end of the first part of the wrap and the beginning of the second.

    For the language-lexer you are choosing that’s causing this (I’m assuming that you don’t have free-form Latin/Lorem Ipsum text in ActiveScript normally), either someone else will more knowledge in this area can help you configure that more specifically, or you might have to choose between having the features of the lexer that you desire vs the word wrap. (Personally, when I code, I’d rather have the lexer information than word-wrap; but it’s a decision you may have to make for yourself.)

    (not affiliated with N++, Scintilla, any of the lexers; just a N++ user trying to be helpful)



  • some video gif
    Alt text

    “to turn off the Language setting”
    but if i need it?!
    i create bbcode colors from
    Configuration bbcode pour notepad++
    http://fredcrash.dyndns.org/bbcode/index.php



  • Anybody help me?!



  • I’ve done a few UDL languages myself, and never noticed any configuration switch for how it interacts with NPP’s word-wrap. My reading of the UDL 2.1 documentation (http://ivan-radic.github.io/udl-documentation/) (or it’s 2.0 predecessor at http://udl20.weebly.com/) have never noticed anything like that, but you might want to read the documentation to see if there’s something that helps you.

    If you must have word wrap and must have your User Defined Language both active at the same time, you will probably have to find an alternate solution. Some possibilities come to mind:

    1. contact the person who documented the UDL 2.1 feature (the documentation may point you to his contact info). He may know more of the internals on how UDL interacts with the word wrap, and if asked nicely, may be able to help you – answer your question, or add a feature to the next revision of UDL which allows the user to select how a specific UDL interacts with NPP’s word-wrap feature. Or he may be able to point you to someone who does know and/or can help.

    2. search for an existing BBCode plugin (lexer or otherwise), which is coded specifically for the unique requirements of BBCode; if that plugin/lexer doesn’t handle word-wrap the way you want, ask the maintainer if a configuration toggle can be added to change how spaces wrap.

    3. ask someone to write an NPP lexer or other plugin that meets the exact requirements that you need.

    Notice on any of these, asking nicely may include bribery or actual payment. If it’s something you must have, you may have to decide if it’s something important enough to pay for.



  • this bug on standart setup. u see my gif? no bbcode!


Log in to reply