Failure to Launch

  • Notepad++ 6.9.2 has stopped launching. Well it starts (it shows up in task manager) but opens no windows.
    I have uninstalled, cleared all the …/appdata files and cleaned the registry for every user and re-installed. It will open as administrator but not as another user.


  • Got the same Problem!

    Yesterday everything is fine - now, today: N++ wont launch.
    Just the process in taskmanager is visible but Application is not starting.

    Deinstallation/Reinstallation: no difference.

    Clueless …

  • Me too.

    N++ worked yesterday. It will not load today. Version on Windows 7.

  • Hmpf … this is bad. I have to work with it professionally - and daily.
    Searching for alternatives … Sublime looks good.

    So, lets wait till tomorrow and see.

  • I also uninstalled and tried 6.9.1 but that didn’t work. I shut my anti-virus program off. That didn’t help.

  • @Adam-Thorpe
    Well I didn’t delete everything. Uninstall leaves files under …\Program Files. So I did the same again and also removed everything from the install directory. Now it works again. No plugins or custom language coloring, just a bare notepad++

    So where exactly does notepad++ store the custom language definitions and can I transfer that file to my laptop and get the notepad++ on my laptop to see the same language definitions?

  • Aaarrgh! So now I have tried to re-install the Explorer plug-in and it instantly died again. So there seems to be an explorer incompatibility here. Also now it won;t run as Administrator either

  • Had exactly the same problem. In desperation I tried to use Atom and it was horrendous - I’m too used to my keyboard shortcuts and easy column editing. Anyway, I got NPP working again by disabling the Light Explorer plugin. I then tried to use the Explorer plugin (installed via the plugin manager) and NPP wouldn’t open again. Disabling the Explorer plugin solved the problem so it looks like I have NPP without any kind of file list which is a pain. NppFTP and TextFX plugins work so I’m thinking that it might be a Windows update that is preventing file listing or something along those lines. I’m running NPP as Administrator on Windows 7 64-bit.

  • I had the same problem. It seems it is a compatibility problem with the last dropbox version.

    In my case, i uninstalled dropbox and explorer plugin worked again.

  • Sounds interesting, Florentino. I’ve dropbox installed too.
    Just disabling it seems not to be enough (“exit dropbox”) even the process in taskmanager is gone, n++ wont start.

    Hm … dont’ want to deinstall dropbox, its necessary for my Cloud-Backup.
    Testing Sublime now.

  • By the way: Nadeem, how can I disable the Explorer plugin?
    Just moving the explorer.dll seems not to be enough.
    How do you start the PluginManager without starting N++?

  • Anton - I just need to move the .dll file into the “disabled” folder. However that didn’t work the first time around for me either. I had to do a complete uninstall, delete the %appdata%/notepad++ folder and remove all configuration files (including the ones stored by Dropbox/GoogleDrive/etc if you’ve set a cloud backup) then do a fresh, clean install.

  • Uff … okay, thanx Nadeem! Seems a lot of work …
    I will try this later.

    Now I explore Sublime - its interesting.
    But the FTP-Plugins are not so well, seems to me. There is no permanent window to browse.

  • Removing Dropbox fixed the problem with NPP. Unfortunately, I need Dropbox more than NPP. I hope this gets fixed soon. Like other people have written, I need Dropbox.

  • @Florentino-Gracia Thank you, sir! Uninstalling dropbox (which showed an update date of 8/19/2016) solved it for me, too.

  • Renaming the Program Files (x86)/Notepad++/plugins/Explorer.dll to something like Explorer.dll.old will allow NPP to invoke again. I emailed the Dropbox technical folks - they may or may not be aware that their latest update screws with NPP.

  • Jfyi -to start npp without any plugins loaded (they don’t get deleted/renamed etc… just ignored) use the -noPlugin switch.
    See ? menu -> Command line arguments.


  • ---------------- FIX ----------------

    I just found the problem of Dropbox. The problem is in the Shell Explorer DLL of Dropbox (that takes care of things like the sync icons in Windows Explorer in the Dropbox directory).

    You can still use Dropbox AND Notepad++ using the following method:

    • Download ShellExView from NirSoft. Make sure you download the 32-bit version of ShellExView, because Notepad++ uses the 32-bit DLL’s of Dropbox.

    • Start ShellExView and sort the list by Description.

    • Select all the items from Dropbox

    • Disable all the selected items by pressing F7, or right-click->Disable selected items, or click the red-dot-icon in the upper toolbar.

    • Explorer.exe already loaded all these DLL’s, so restart explorer.exe with the Taskmanager, or just simply log out in Windows and login again.

    • Now Notepad++ should start, with any explorer plugin’s enabled and with Dropbox installed.

    Possibly this fix will be temporary, because Dropbox can update the DLL and I don’t know what happens with the disabled items. But of course you can just run ShellExView again to fix this.

    I encountered the problem using the LightEplorer plugin and the WindowManager plugin in Notepad++. Now it all works again.

  • Thanx, Joris. Hope, there will be a solution from the NPP-Developer(s) soon.

Log in to reply