Suggestion for 64 bit plugin naming convention
It seems like the current plugins for the 64-bit version of Notepad++ (mimeTools.dll and NppConverter.dll) have the same file name as the 32-bit version. This could cause confusion if someone is copying these .dll files from somewhere else (another folder on the same PC, or from some internet website).
I would suggest that when plugin authors create a 64-bit plugin, they append “_64” to the DLL filename. So “mimeTools.dll” becomes “mimeTools_64.dll” and “NppConverter.dll” becomes “NppConverter_64.dll” so that it is clear these are 64-bit plugins. The old 32-bit plugin names don’t have to change (if you don’t see “_64” then you assume it is the 32-bit version).
It would be better if 64-bit plugins in %APPDATA% can reside in a different folder from 32bit plugins, such as plugins_64. In which case, 64bit and 32bit notepad++ can both work properly without conflict loading each others plugins.
Putting them in a separate folder would be fine, but there is still confusion just looking at the filename to tell if they are 32 bit or 64 bit executables. You can’t even right click on the file and look at the properties to see if it’s 32 bit or 64 bit.