Can't Change Autocomplete "From 1 th Character"



  • Hi,
    I’m using Notepad++ 6.9.2 under Win7 and can’t change under Preferences/AutoCompletion the character number from which on auto completion should start. The pop up window does not accept any number I type. I even tried to change this setting in config.xml (inside the Notepad++ folder), but this doesn’t work either :-(
    Any idea what I’m doing wrong?

    Many thanks,
    Axel



  • I have the same problem on v6.9.7 under win7 x32



  • @prontom

    6.9.7 ??
    Are you sure?
    Afaik there was no 6.9.7. There is a 6.9.2 and the most recent version 7.0.

    @Axel-Kowald
    @prontom

    Could it be that you are editing the wrong file?
    Do you have APPDATA or local installation.
    What about renaming the APPDATA\notepad++ directory (of course, only if used).
    Screenshots?

    Cheers
    Claudia



  • I’ve updated the program to 7.2 Screenshot



  • @prontom

    Screenshot looks ok.
    You know that you can only use numbers from 1to 9 as stated in window?
    If you open the dialog and click on the number after “From”,
    the little window should pop up and the number should be selected.
    Just overwrite it with another digit.
    If you have deselected the number, delete it by pressing backtab or del - depends where
    the cursor is and type in a new digit.
    If this doesn’t work, edit the file config.xml in D:\Programs\Notepad++.
    Search for the line with auto-completion and change the value in triggerFromNbChar.

    Cheers
    Claudia



  • Hello. Same problem. The windows does not allow to enter any number (v 7.5.8) . I have modified config.xml in C:\Users\Geoffroy\AppData\Roaming\Notepad++. I had to do the modification with another text editor because notepad++ reset the value to 1 when it closes.
    The very best way would be to fix the bug of the windows, isn’t it ?



  • Same story here. The only solution available for the meantime is just manual update of the settings file.



  • Update:
    Same story here. The only solution available for the meantime is a just manual modification of the settings file at: “C:\Users\User\AppData\Roaming\Notepad++\config.xml”
    Line to fix:
    <GUIConfig name=“auto-completion” autoCAction=“3” triggerFromNbChar=“XX YOUR # HERE XX” autoCIgnoreNumbers=“no” funcParams=“no” />



  • @Bilal-Qindeel and/or Stephane Latour :

    Have you checked to see if this is an “issue” here ? Without it being an issue, it isn’t going to get attention.


Log in to reply