Disabling Tab Button Selection of Auto-Complete.



  • As expected when starting a new word, the auto-complete box is shown and the first option highlighted.

    In order to select an option from the box you can either hit enter or tab.

    If you hit space, then the auto-complete is cancelled and a space is inserted into the text.

    Can anyone tell me how to change it so as hitting tab would not select an option, but rather insert a tab.



  • Hello, Chris Mckevitt,

    Very easily, indeed ! Instead of pressing the Tab key, Chris, just hold down the Alt key and hit, successively, on the Numeric keyboard, the two 0 and 9 keys => The auto-complete box is, then, closed and a single tabulation character ( \x09 ) is inserted, at the caret’s position :-)) Et voilà !

    I verified that it’s OK, for, both ,completion of functions AND completion of words

    Of course, it’s not as straight as hitting an unique key, but just consider it as a work-around !

    Best Regards,

    guy038


Log in to reply