Notepad++ can't handle a 10MB text file



  • Hello,
    I have two tab-separated termbases in txt file format, each in different language combination and with about 1 Mio. lines. I update and maintain them with Notepad++ and Excel. The length of the lines in each termbase is usually up to 100 characters and the file size of each termbase is about 30 MB. When I do editing even on a separated chunk with about 300,000 lines or 10 MB in size, Notepad++ sometimes screws up all text in it, producing strange characters (Non-Unicode? - I don’t know what they are called). It also removes the first letter of each line like:

    Before:
    first letter TAB erster Buchstabe
    first letters TAB erste Buchstaben

    After:
    irst letter TAB erster Buchstabe
    irst letters TAB erste Buchstaben

    In that case, undo doesn’t help either, and those strange characters/codes stay where they are.

    Is a 10 MB text file with 300,000 lines really too big for Notepad++ to handle without problem? Is there anything that can be done for this? I now use the 64bit version.



  • I have routinely edited 200MB files. There are a couple things to do:

    • Disable sessions snapshots and periodic backups. (this can cause large files to get corrupt)
    • Settings > Preferences > Auto-Completion and make sure it is not set to do word completion (this can cause large delays in editing the file, however it may not be required since your file is only 10MB).
    • If that doesn’t work disable plugins if you have any installed.


  • Hello Glossar,

    I’ve just build, five minutes ago, a big file of 50,006,100 bytes, containing 1,705,370 lines, about. NO trouble at all, even on my very old XP configuration, with ONLY 1 Mb of RAM !! The search of the last line, from the first line, take 2s, about. I’ve got, presently, 36 files opened in the last 7.2 version of N++, whose this big file. And if I stop and re-start N++, 3 seconds after, all the tabs are accessible !

    In addition to dail’s suggestions, one more trick : disable the word wrap feature ! Click on the appropriate button, on the toolbar or de-select the menu option View > Word wrap, if enabled. I noticed that It may help, while navigating between locations in a big file !

    And, of course, don’t forget the valuable operation of re-starting your computer or laptop ! It generally solves 95% of problems :-))

    Best Regards

    guy038



  • Dail - Thank you! I’ve disabled this “snapshots and periodic backups” feature. I don’t use Auto-Completion, so it is already disabled. And for the 64bit version, there are no extra plugins to be installed anyway, except those few installed by default. Still I could, or would want to, uninstall the “Converter” and “MIME Tools”, if needed.

    Guy038 - Thank you! Your numbers are amazing! I’ve now disabled the word wrap feature as well.

    I hope I don’t encounter the problem anymore.

    Again, thank you both!


Log in to reply