Shortcut to replace all in replace dialog no longer works

  • Hi,

    I am using often “alt + a” shortcut to trigger “replace all” functionality in the replace dialog (opened by ctrl + h).
    Now instead of replacing, it invokes “find all” functionality. Has anyone noticed this as well? It is annoying, it has worked so well before.

    Just to be clear - the replace functionality works fine if I click the button with mouse. It’s the shortcut that is not working.

    Npp version 7.2.1

  • Mine is the same - on v.7.2.1.

  • You can change that “shortcut” but it is not done via the normal “Shortcut Mapper”; see this posting for how:

    That link discusses the English language, but I believe the general idea works with any language you might happen to use.

  • @Scott-Sumner Thanks, will try this.

    Its unfortunate that i have to resort to such magic. The “Replace All” button has capital “A” underlined, and it is a standard in windows that “alt + letter” would trigger this. Will post an update after i’ve tried this.

  • @Darius-Damalakas

    It appears that between 7.2 and 7.2.1 the “FInd All In Current Document” was assigned Alt+A as a keyboard- accelerator. This appears to be a duplicate assignment, since as you point out, the “Replace All” button has the “A” underlined. When you press Alt+A, the software finds the “Find All in Curr Doc” binding first and invokes that. The technique I linked to earlier should allow you to fix this.

    Regarding “resort(ing) to such magic…”, I guess the positive takeaway is that you can fix such things yourself without waiting on someone else to do it. And for some people that stretch Notepad++ to its utter limits, the “magic” is sometimes indispensable. :-)

Log in to reply