Windows not recognizing Notepad++



  • For some annoying reason, when trying to open .XML files windows doesn’t recognize Notepad++ as a default program. ie. when doubleclick on the file and it says “open with existing program” when i click browse and find Notepad++ it just sends me back and doesn’t allow me to make it the default program, which means every time I go to open a file i have to manually open it with Notepad++. Any help on the subject would be appreciated.



  • Could you provide more information about your system(windows)?
    Please copy debug info here.



  • I’m running Windows 7 64 bit.

    Debug info:

    Notepad++ v7.2 (32-bit)
    Build time : Nov 2 2016 - 11:26:20
    Path : C:\Users\User\Desktop\Programs\Notepad ++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows 7
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll PluginManager.dll



  • @Placeholder

    permission issue ??
    What if you run Default program and set npp for the extension?
    Or what about running npp as administrator and do assignment via Settings->Preferences->File Association?

    Cheers
    Claudia


Log in to reply