How to restore grouping in the 'Language' drop down?



  • This drove me up a wall and wasted my time, so here’s a quick answer for anyone coming after me:
    Settings > Preferences… > Language > [ ] Make language menu compact

    The initial complaint, for search keywords and problem context:

    After I installed Notepad++ on a new machine, I noticed the Language menu no longer groups languages alphabetically.
    This made it difficult to select the type of syntax highlighting I want, as the list does not resize and is unusable on my second monitor: How do I select XML highlighting there?

    I have mixed-content files which makes it useful to highlight them in different ways at different times, so I can’t just bind the extension to one highlighting mode and be done.

    How do I re-enable grouping the language menu?


Log in to reply