Problem with ? -> "Set Updater proxy..."

  • Hi,

    On work, I have to set a proxy and I wanted to also set in n Notepad++ for program updates.
    (I don’t have the problem with the plugin manager…)


    • in “?” menu,
    • then “Set Updater proxy…”
    • if I set it, “Ok”,
    • then reopen it,
    • it is back to “”

    I had the problem with previous version and also the new one 7.3

  • @ArfyFR

    don’t have the issue here (using also latest 7.3).
    Could you provide ?-debug->info, please.


  • @ArfyFR

    value is saved in C:\Program Files\Notepad++\updater\gupOptions.xml
    could it be that you have write permission issues?


  • Hi, I have noticed this same issue. I do not have a gupOptions.xml. There is no such file in that folder. There is a gup.xml but this does not have any proxy reference. Thanks. Andrew

  • Notepad++ v7.3 (32-bit)
    Build time : Jan 1 2017 - 20:04:42
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll PluginManager.dll

  • @Andrew-Raison


    can it be that you do not have write permissions to that folder?
    As the zip doesn’t contain the file itself, I assume that it gets created when needed.

    Content of the file looks like


    maybe create it manually?


  • I’m a local admin but think the issue may be because of UAC. I created it manually and got a UAC prompt to save it. It can now check for changes. Thanks.
    Problem is now there is about 10 of us who have it installed so need to push this xml file out to them as well.
    Thanks again for the assistance, Andrew

  • Permission issue. Just run C:\Program Files (x86)\Notepad++\notepad++.exe as administrator (right click, run as admin.) and it will keep the proxy settings.

Log in to reply